CR2 and DNG thumbnails in Nautilus

nautilus

#1

Hi all,

I’m using GNOME on Ubuntu 18.10 and it’s default file manager Nautilus to manage my photos since I cannot conform to any management software like Digikam. And I tried many times but I always end up managing my photos in nautilus.

Now the problem is; I shoot raw with my Canon 77D (CR2) and DJI Inspire 1 (DNG) and I cannot see any thumbnails in Nautilus for those two formats. Or any other raw format for that matter.

The current process that I have to create thumbnails now is to use gThumb to open a folder with (sometimes thousands) images and let it create the appropriate thumbnails. That’s a very slow and painful process which takes away significant amount of my time.

I’ve tried solutions proposed on the web and installing gnome-raw-thumbnailer and some similar tools but it always ends up with me loosing the thumbnails or it takes hours to generate thumbnails for even just a few images.

My dear fellas, has anybody solved this successfully for themselves? If you did, please share the solution here b/c getting those thumbnails is such a pita for me.

Thank you all!


(Glenn Butcher) #2

That’s one of the reasons I stopped using Nautilus and moved to Geeqie, it deals with whatever format, and speedy-quick at that. You can configure the Edit menu to include your favorite software, but I just make desktop icons for my softwares and I can drag an image from Geeqie to it to open…


#3

I can test to see that workflow but I’m still looking for the solution of thumbnails in nautilus :slight_smile:


(Damon Lynch) #4

If you download the files with Rapid Photo Downloader it will create the thumbnails for you as it downloads.

For your existing files, it will not help however.


(Thomas) #5

With Archlinux I just had to edit the file “/usr/share/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer”

and add “image/x-xpixmap;image/x-canon-cr2;” to the line starting with “MimeType=”.

I do not know whether this works under Ubuntu.

Edit: Just checked in a Virtual Machine. Works also on Ubuntu 18.04.


#6

Thank you so much!
You have just solved all my problems :DDDD
It works, and it works pretty fast :smiley:


(Thomas) #7

You are welcome. I also use a canon camera and find this feature in nautilus pretty neat.