CR3 on Fedora (darktable 3.8)


I tried to install darktable 3.8 on Fedora 35 with CR3 support, but with no success.

I also tried to check if exiv2 is with BMFF support enable, but I don’t know how to check it.

I hope you guys can help me.

Thanks in advance.

Where did you get the packages?

1 Like

I get the packages of darktable from Fedora RPM and ̶F̶l̶a̶t̶h̶u̶b̶. (edit: actually from Fedora Flatpaks)

The exiv2 package is from Fedora RPM.

  1. Fedora exiv2 does not yet support isobmff. For details see 1979565 – New file formats not enabled during exiv2 build
  2. not sure which exiv2 library the flatpak package is using.
  3. the OBS package of darktable has CR3 support if you also grab exiv2 from the OBS repository. See install | darktable

If your using the latest flatpak, it should work.

1 Like

I double-check the flatpak install, and it seems that I had installed the package from Fedora Flatpaks instead of Flathub. So I installed it from Flathub, and it reads CR3 files. My bad.

Nevertheless, thank you for your help @paperdigits and @darix.

No problem, glad you got it working. Welcome to the community!

1 Like


I will open another thread, because I can’t open darktable with opencl enabled.