crop & export: is resize a must

Hi, I am new to rawtherapee and trying to make it work :slight_smile:

When I crop the image and then save it through quick export I get the jpg exported along with black field that covers the “cropped” part of the picture.
However, if I use ctrl+S I cannot control the size of the picture.
Do I do smth wrong or do I always need to use resize function as well?
thanks

Can not reproduce here:

I cropped an image

Then added to the queue this way:
grafik

Then processed it in queue. No black borders:
grafik

2 Likes

hmm… ok, so maybe my screens give you an idea. the crop area is not marked with dash line (but for some other it does). I dont use any pre-saved processing profiles either:
crop1

Your screenshot does not show the exported jpeg.

May be @chava_baila is looking at the raw in the file browser part of the RT and seeing the black border. That image is different from the exported jpg.

Continuing with @shreedhar’s explanation, it seems you’re looking for the exported file inside the folder where the raw is located.

If the Queue settings are the default ones,

converted%20template

then you should be looking into «Summer 2019/converted»

converted%20folder

(double clic the converted folder in the File Browser)


If you need/want the converted files alongside the raw files, the Queue template should look like this:

converted%20custom


And if you need some custom template, take a look at the Rawpedia documentation.

Welcome @chava_baila

After editig your image in the editor and when you are satisfied, you must process your raw files with the selected parameters included in the sidecarfile .pp3. This exports an output file (jpg, tiff or png)
Your raw file is absolutely never modified by Rawtherapee.

see
http://rawpedia.rawtherapee.com/Queue
http://rawpedia.rawtherapee.com/Saving_Images

1 Like

the jpg was in the original post, and here I post so that it is seen better:
Screenshot_2019-08-04_17-24-02

@heckflosse

Ok, I have replicated the issue and now I think I see what’s happening: most probably you’re using

Fast Export Options > Processing pipeline > Dedicated

and the Maximum size indicated in the Resize part is bigger than the cropped size of the image.


E.g.: the cropped image measures 300x400 pixels, and the Maximum width and Maximum height are bigger, say 1500x2000 pixels. In this case the exported image has the same size of the raw file, with the crop at the top left corner, and everything else is filled in black.


Most likely this is a bug, but a workaround would be using

Fast Export Options > Processing pipeline > Standard

and unselecting all the Processing steps to bypass



Hope this helps

P.S.: by the way, in Batch Export cropping and resizing are two completely different things.

2 Likes

@XavAL, Thank you!
Now, stupid question: how do I know pix size of the cropped image?

Easy to answer :slight_smile:

crop%20size

In this example the crop size is 1130x1315 px

1 Like