Custom G'MIC Script not showing up

Hey folks! It’s my first attempt at writing a custom script, so I’ve been following The Wiki instructions but with no luck.

Creating a TextEdit doc, named .gmic, and placing it in my Home directory (which if I am correct on a Mac it’s at Shift Command H) and just writing this:
#@gui My first filter: my_first_filter_command, my_first_filter_command_preview

This isn’t showing up in the list of filters.

Refreshing the G’MIC plugin should show that in the list but I must be missing a key step. I made sure the text file was in plain text. It’s in my Home directory. I am running the latest Macports version of Gimp with G’MIC 2.8.4 on a Macbook Pro Retina Sierra 10.12.6.

Let me know if you need anymore info.
Thanks for the help!

Hi, I have copied your line into my .gmic file ($_path_user) and

Still I have an additional line

#@gui { KaRo’s .gmic }

at the beginning.

I am on Mac using MacPorts too.

Well gosh darn it what am I doing differently?

@KaRo thanks for the reply. Your .gmic file, is that its name or is it something like my_filters.gmic?

And do I have it at the right place here:

Could it be that your file is actually named ‘.gmic.txt’ rather than ‘.gmic’, and the extensions are hidden in some way?

That’s what I was thinking! But I haven’t been able to find a way to change the format. I noticed that only my script attempt has that txt on its icon. When “get info” it says it’s a plain text document, and when I saved it prompted me to “use ‘.’”

This might be a TextEdit thing I’m not aware of. Is there another program I should use to write it?


I had a look at the saved file with get info, tapped the Name and Extension drop down menu and found indeed it was .gmic.txt!!!


Thanks for the lookout @David_Tschumperle
Have a great day!

For this reason, I always expose the extensions. :wink:

I can see why! How might I do that if you don’t mind helping?

You find it under Finder->Preferences->Extended. Still I would only switch it for certain files in file Info, not for all!

Thanks @KaRo!

As a complete noob to speaking Computer, thank you all for the help. This has been a fun rabbit hole to learn what my terminal can do :smile: