Custom GTK3-theme "blackfoxx" (and instructions to disable tooltips in RT)

@blackfoxx many thanks for your detailed instructions.
I will give it a go…

Why would you disable tooltips? They are quite helpful imo…

Yes, for sure, for beginners. But if you are familiar with the software after some time, they might become annoying. Furthermore they are sometimes covering useful informations, such as parts of a curve, settings, sliders, menus or other tool options.


@blackfoxx list the worst offenders in the GitHub issue I linked above.

Nice job ! :grin:


@blackfoxx @agriggio
Sorry if this isn’t the right place to report this, not sure whether this is a problem with the theme or ART.
I have found the crop tool is a bit glitchy with this TooWaBlue or BlackFoxx theme.
If you don’t have ‘lock ratio’ box ticked when making the initial selection then the preview will display an incorrect crop.
Crop selected

Crop preview in BlackFoxx theme

Crop preview in RawTherapee theme

Have noticed this problem with versions in the past, then forgot about it. Seems to be a problem with a range of raw file types. I am on Windows 10 (reluctantly)
Hope this helps…

thanks for reporting, but there’s not much I can do I’m afraid… I’m only supporting the default theme, other contributions are welcome but I can’t maintain them, sorry

@agriggio Yes I would take that as given. The original themes were designed for RT. People may need to change them to get them to work with ART…

Hi :v:
As I don’t have ART installed currently, I can’t say something about that “issue”.
Unfortunately I’m very busy these days, so it might will take some time to find the cause.

I don’t think this is something that you should feel obliged to sort out. You created a theme that you use with RT and were kind enough to share it around. It mostly works with ART but this is a different piece of software going in a different direction so not surprising that not all themes are compatible with both.

Yes, for sure, I know what you mean :wink:
But maybe it’s just a small thing to do, to get it right…
I will definitely take a look, as soon as I have time for it again.

I’ve used the TooWaGrey theme in both ART and RT, and I haven’t noticed any particular problem… :thinking:

Perhaps the problems with the crop tool under these themes only happen in particular instances that I happened to be using. Seemed to be replicable though…

Hi :v:

At first:
I was able to retrace this “problem” within ART_1.0_Win64 as well as in
Exactly as @spidermonkey described.
Thereupon I compared the blackfoxx-GTK3-20_.css and the TooWaBlue-GTK3-20_.css
with the RawTherapee-GTK3-20_.css. I was just looking for keywords, such as “crop”, “preview”, “window” etc. And found only ONE entry in RawTherapee-GTK3-20_.css which didn’t exist in the blackfoxx or TooWaBlue file. So I added this one entry

#PreviewWindow {
border-style: solid;

to the blackfoxx and TooWaBlue file, but nothing changed…
However, this “error” must be in these two .css files, otherwise it wouldn’t work with the original RawTherapee-GTK3-20_.css.
But unfortunately I don’t have time to compare this 2130 lines of code in the blackfoxx/TooWaBlue themes with the 1356 lines of the RawTherapee theme one by one.
But maybe @TooWaBoo can take a look here too?!

During these investigations I found another “problem” within RawTherapee :expressionless:
In fact, while using the crop-tool in ART:

  • creating any selection
  • switch back to hand-tool or click crop-tool once again
  • selection will be cut out and displayed without the remaining picture within the preview-window

ART crop-tool after drawing an selection:

ART crop-tool after switching back to hand-tool or click on crop-tool again:

And while using the crop-tool in RawTherapee:

  • creating any selection
  • switch back to hand-tool or click crop-tool once again
  • nothing happens after that

RawTherapee crop-tool after drawing an selection:

RawTherapee crop-tool after switching back to hand-tool or click on crop-tool again:

It remains the same. No matter which tool is chosen after drawing an selection, nothing happens!

Even the selection can’t be moved around within the picture, without changing it’s values or creating a new one… :thinking:
AND: in case of this second “problem” it doesn’t matter which theme is applied!

I don’t know if this behavior is “normal” or another issue?!
Maybe somebody else can say something about that?!


Click any of the marked buttons instead of the leftmost button

Ah, okay. Thanks for your hint. It works.
So the remaining parts of the picture will be replaced with the chosen background color.
But moving the selection around (without changing it’s values) within the remaining picture still doesn’t work…

Thanks for your investigations so far…

1 Like

Meanwhile I also found out how to move a selection around within the remaining picture:

  • Just hold the Shift-Key while moving the mouse. :see_no_evil:

So the whole second “problem” from Post 21 is just solved :sweat_smile:

It’s a good idea to see the documentation before reporting a potential bug.

Yes, of course. I already did, but maybe it was too long ago.
And as I need the crop tool very rarely (I try to photograph that it fits from the beginning)
I just forgot about about that Shift-Key…