"Customize Clut" color picker issue.

Hello all and Happy new year :slight_smile:

Using Gmic QT latest 2.1.8 version with Gimp 2.8.22, both x64, i have an issue with the color picker of the “Customize Clut” plugin.

Each time on the first color pick i get a kind of pink tint, i need to repeat the color picking a second time to get the correct color picked. I put a short video showing the problem here :

It ain’t the same variation of pink i get each time i first pick a color, the RGB values changes slightly but it’s always this kind of pink tint.

I have no idea why it does this, problem was also present in 2.1.7 version of Gmic, no sure for the previous ones as i did not used this plugin much before. This said i have no issues with Gimp itself and the color picker, only here.

If anyone have a clue about this issue please, not sure if it’s a bug or if it have to do with something else.

Thanks in advance, and thanks for this wonderful tool that is G’mic.

Thanks for the report, I’ll forward your message to the developer of the plug-in interface !

1 Like

Thanks to you :slight_smile:

Did you manage to reproduce the same thing yourself ?
Just wondering if it’s a global problem/ bug or if it’s specific to some configurations maybe.

Thanks again.

Actually, I’ve just tested, and no, the color picker works as expected on my machine (running Ubuntu 17.10, Qt 5.9.1). That looks like a bug in the Qt library, maybe another Windows user could check ?.

1 Like

Not experiencing this problem. Using GIMP Std from @partha on win7.

image
image

1 Like

Thanks,

Arg this doesn’t sound good :confused:
I’ll install and give a try to Gimp 2.9.x tomorrow just in case, I just hope it’s not an isolated thing so it is possible to get it solved.

Or try to put my hands on the older version of G’mic you are running, the 2.0.4 and give it a try too on my current gimp

Thanks a lot.

Hello,

Gave a try with G’mic 2.1.8 and Gimp 2.9.8 and still the same issue.

Noticed it isn’t limited to the "Customize Clut " filter btw, for example the filter “Select-Replace Color” have the same problem when using the color picker.

Another strange thing is that the color picker seems to have issues only if i try to pick a color inside another window like in the preview mode one, if i try to pick a color inside the color picker main window itself it works as expected, see here :

  • No problem on the main color picker window
  • Pink tint on the first pick inside the preview window
  • No problem on the second try to pick a color.

Thank you.

@Yalba I don’t use the color picker within these filters but you are right about it not working as expected when picking from another window. A temp workaround might be to select the color beforehand to see what its color coordinates are and then manually type it in when you use the filter.

2 Likes

Thanks a lot for confirming it @afre , at least now i am sure it’s not only something on my end :stuck_out_tongue:

Well the easiest solution is to pick twice the colors rather than collecting and entering them manually, bit tedious with filters like Customize Clut when you want to change a bunch of colors but there is no other choice for now.

Hopefully someone will find out what is wrong with the color picker and find a way to fix this one of those days.

Don’t know if this problem was present before the QT’s versions of G’mic, if someone still have a non-QT based version installed and can give it a try…

Thanks again for the help.

@Yalba @David_Tschumperle I tried using GIMP-2.9.8 18794a6ba2 and G’MIC-Qt-2.1.5 and it works fine here.

imgur-2018_01_05-14:51:28

Tried using both default and dark themes, and with “Use native color dialog” enabled and disabled, with GIMP restarts in-between - always worked fine.

I self-compiled G’MIC using Qt-5.9.3 apparently.

@Yalba have you tried changing “Use native color dialog”?

2 Likes

Hello,
I just tried both to enable native colors and also switch to default theme, restarted gimp in between and same results.

I use the latest stable version: 2.1.8 Qt, not sure of the Qt version used in this one, when going into the plugin folder and looking at the Qt5Core.dll details proprieties in windows i see 5.8.0.0, same version for all other Qtxxx.dll’s i checked.

I can’t compile stuff myself but changing the QT version could be something to test if possible.

Thank you.

Tested last 2.1.9_pre in GTK version and there is no problem with this GTK version.

Looked a bit around to see if i could replace the Qt dll’s that come with G’mic in version 5.8.0.0 and simply replace them with newer versions like 5.9 or 5.10 but there is loads of files at https://download.qt.io/official_releases/qt/5.10/ and not sure if there is what i need there ( most files need to be compiled it seems ).

Well not even sure if G’mic would work after simply replacing the Qt5Core, Qt5Gui, Qt5Network, Qt5Widgets dll’s with more recent versions of those dll’s or if needs to be compiled directly with those to work ( I’m not a compil’ guy :confused: )

Hi, I know this is an old forum thread, but I seem to be having the same problem.I use GMIC on Krita (for some reason I couldn’t get it on GIMP, it kept giving me error messages) but Krita GMIC is giving me the same problems with customize CLUT.