darktable 2.4.2 released


(system) #1

we’re proud to announce the second bugfix release for the 2.4 series of darktable, 2.4.2!

the github release is here: https://github.com/darktable-org/darktable/releases/tag/release-2.4.2.

as always, please don’t use the autogenerated tarball provided by github, but only our tar.xz. the checksums are:

$ sha256sum darktable-2.4.2.tar.xz
19cccb60711ed0607ceaa844967b692a3b8666b12bf1d12f2242ec8942fa5a81 darktable-2.4.2.tar.xz
$ sha256sum darktable-2.4.2.dmg
2b0b456f6efbc05550e729a388c55e195eecc827b0b691cd42d997b026f0867c darktable-2.4.2.dmg
$ sha256sum darktable-2.4.2-win64.exe
5181dad9afd798090de8c4d54f76ee4d43cbf76ddf2734364ffec5ccb1121a34 darktable-2.4.2-win64.exe
$ sha256sum darktable-2.4.2-win64.zip
935ba4756e208369b9cabf1ca441ed0b91acb73ebf9125dcaf563210ebe4524d darktable-2.4.2-win64.zip

when updating from the currently stable 2.2.x series, please bear in mind that your edits will be preserved during this process, but it will not be possible to downgrade from 2.4 to 2.2.x any more.

Important note: to make sure that darktable can keep on supporting the raw file format for your camera, please read this post on how/what raw samples you can contribute to ensure that we have the full raw sample set for your camera under CC0 license!

and the changelog as compared to 2.4.1 can be found below.

New Features

  • Add presets to location search in map mode
  • Add timestamps to the output of -d command line switches
  • Add a compression level slider to the TIFF export module
  • Add native binary NetPNM loading, without using GraphicsMagick
  • Add a battery indicator for people running darktable on a laptop. This is not very portable code and disabled by default
  • Allow to use /? to show the help message on Windows

Bugfixes

  • Turn off smooth scrolling for X11/Quartz. That might help with oversensitive scrolling
  • Fix reading and writing of TIFFs with non-ASCII filenames on Windows
  • Ellipsize background job labels when too long
  • Hard code D50 white point when exporting to OpenEXR
  • Add tootips to the haze removal module
  • Fix a crash when changing lenses while tethering
  • Fix incorrect Atom CPU detection on Windows
  • Revised performance configuration
  • Don’t overlay the colorbalance sliders on the left for a cleaner look
  • Honor local copy in copy export format
  • Make trashing of files on Windows silent
  • Fix string termination override on memmove
  • Fix a use after free and some memleaks
  • Fix a crash in PDF export
  • Fix the min color picker
  • Don’t hardcode ‘/’ in OpenCL paths on Windows

Camera support, compared to 2.4.1

Warning: support for Nikon NEF ‘lossy after split’ raws was unintentionally broken due to the lack of such samples. Please see this post for more details. If you have affected raws, please contribute samples!

Base Support

  • Canon PowerShot G1 X Mark III
  • Panasonic DMC-FZ2000 (3:2)
  • Panasonic DMC-FZ2500 (3:2)
  • Panasonic DMC-ZS100 (3:2)
  • Sony DSC-RX0
  • Sony DSC-RX10M4

Noise Profiles

  • Canon EOS 200D
  • Canon EOS Kiss X9
  • Canon EOS Rebel SL2
  • Canon EOS 760D
  • Canon EOS 8000D
  • Canon EOS Rebel T6s
  • Canon PowerShot G1 X Mark II
  • Canon PowerShot G9 X
  • Fujifilm X100F
  • Nikon D850
  • Panasonic DC-G9
  • Panasonic DMC-GF6
  • Panasonic DMC-LX10
  • Panasonic DMC-LX15
  • Panasonic DMC-LX9
  • Panasonic DMC-TZ70
  • Panasonic DMC-TZ71
  • Panasonic DMC-ZS50

Translations

  • Dutch
  • French
  • German
  • Hungarian
  • Italian

Share this on: Google+ | Twitter | Facebook


This is a companion discussion topic for the original entry at https://www.darktable.org/2018/03/darktable-242-released/

(Mica) #2

Fantastic job!


(Martin Scharnke) #3

New Features

  • Add presets to location search in map mode

So pleased to have this feature so quickly after suggesting it - originally though it would be in version 2.6. Fantastic work!!! :grinning: I have been using the feature for a few days and am very happy with it.

Bouquets for the developers of this magnificent software.:bouquet::bouquet::bouquet:
Oh - and medals too! :medal_sports::medal_sports::medal_sports:


#4

:thinking: The startup time in win10 is really long (4 min). [After reboot it appears. I closed and opened it again. Same thing. But two opens ago, it was fast. I guess more testing need to be done.]

image


(ph. weyland) #5

On my side I don’t face this issue. In fact I don’t see any startup time difference with 2.4.1.

BTW, thank you so much all for this terrific application ! It deserves really a :medal_sports:


#6

I beliieve that more win10 reports are needed, those with problems. On my lame win10 laptop, the startup time is about 5 seconds.


#7

Might have to do with Windows Defender in my new win10 install. I added an exception and will see how that goes for the next several launches.


#8

Even when using a 3rd party AV (I choose looking only how much they cripple the performance) and most of the Defender is disabled, there is still the SmartScreen feature active, and quite hidden in the settings. It checks the installers against the MS database, so development versions of libre programs are suspicious by default. And even when set to “Warn”, it can and did break the installation. So I have turned this off.
smart
(It might or might not make you more vulnerable to the Russian hackers.)


#9

Just tested on Win10, runs smoothly and performant on my machine, great job!
Greets and happy easter to all
Jürgen


#10

Update: seems to load fast most of the time with an occasional hiccup.


#11

If you can trigger the slowness, please start dt with -d control and have a look at the log file. Since 2.4.2 it puts timestamps next to the log output, so maybe we can pinpoint where it hangs.


(Ramiro) #12

I accidentally discarded the initial pop-up window asking for a performance (re)configuration when launching darktable 2.4.2 for the first time.

How can I get the same por-up window again?

PS: Thanks for a magnificent release and for your continous efforts.


#13

Just remove the line performance_configuration_version_completed=1 from your darktablerc.


(Ramiro) #14

Thanks. It worked like a charm!


#15

Hey guys,

I installed DT on Linux Mint 18.3 from the flathub repository (is that still called repository?) and didn’t get the update yet (I’m on 2.4.0). Do I need to add something like third party sources to get the newest updates that way? Should I stick with the old pmjdebruijn repository?

Thanks a lot for your work,
Oskar


(Mica) #16

Hi @oscar, I’m not sure why you’re not getting the update… I updated the flatpak file the day 2.4.2 was released. Have you tried sudo flatpak update?


#17

Hey paperdigits,
thanks for your help. That brought me to 2.4.1, but not to 2.4.2. I also tried running sudo flatpak update again, running my systems update command, restarting DT / the whole PC and combinations of such but idn’t get 2.4.2 yet.

Oskar


(Mica) #18

I’ll try and see what is going on @qosch


(Mica) #19

I only have 2.4.1 as well. I’ll query the flathub folks