darktable 2.7 strange margin - bug?

Hi,
sorry I have to upload this in original size, but the issue only exists when I export to original size.
So, as you can see, darktable 2.7 produced a strange light margin on the right edge. Why is this? Can somebody reproduce this?


Here is the original raw and the sidecar file:
P2090860.ORF (13.6 MB) [P2090860.ORF.xmp|attachment]

Creative Commons License


This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License.(upload://y3qkHCMTUxdmGOoarTuzsTGXhv2.xmp) (103.7 KB) P2090860.ORF.xmp (103.7 KB)
Thanks in advance
Anna

Yes, I can (with your xmp file. With my own edits, the export was fine)
And there’s also a temporary file left over after the export (which took forever…):
b5fe5eef23eaabac4f883fee2f408629f1b44408
I would file a bug.
EDIT: Ubuntu 18.04 here.

1 Like

Moinchen, Anna!

No. The margin looks OK here
(using Linux and the latest darktable-git).
Perhaps a peculiarity in the Win version?

MfG
Claes in Lund, Schweden

1 Like

Using MX Linux 19 here.

Morning, Rei!

Oh, you could reproduce the error? Good!
What dt version are you using?

My memory tells me that I have read something about “odd file types”, i.e. a file type sometimes (?!) receives an extra suffix, like the 3037 in your case. I’ll have a look…

Have fun!
Claes in Lund, Sweden

Morning, Claes!
git2112.b04bbeb29

This seems to be related with her edits.
I had previously edit my own way and the export was fine.

I guess some module is causing the problem but which one?
My version is 2071-gcd3cf4669, I think, at least that is what is written right after 2.7.0.

I never saw that gcd naming pattern before, but the fact is that I could reproduce the issue with my own version:

image

… which seems to be almost up-to-date, according to github. It only lacks the latest spanish and polish translation updates.

File a bug and give them your raw and xmp files

EDIT: @betazoid it seems there’s already a similar bug filed: https://github.com/darktable-org/darktable/issues/3151

Maybe you should add yours to that one, I don’t know. It seems the same.

1 Like

I think a raw file is actually not needed. I copied the story stack to a different raw - very similar result.


Can someone check if this happens with other cameras as well?

I think it is not exactly the same thing

Anyway, I am still waiting a bit until one of the devs says something - or are you one of them?

Same thing with a RAF file.
EDIT: I mean, I loaded your xmp file into a RAF file.

No, I’m not.
I think DT devs focus more on github issues report and they are very low profile on discuss when it comes to bugs. I wouldn’t wait for them. This is clearly a bug.

1 Like

ok, thanks for checking

Abends, gnädige Frau…

I have been thinking about your problem today.
I have read something about odd filetypes from dt, but so far I have not been able to locate any additional info…

What I have done is to fetch the same distro as you are using, to see “with my own fingers” what is happening. That was a bad idea, since MX Linux 19 refuses to load on my machine (I have too modern a gfx) :frowning:

I then tried to approach your problem from another angle:

  • Your history stack has about 40 levels.
  • You have very many created shapes…

Please start darktable from a terminal, using the command
darktable. Open the offending photo in darkroom.

Do you get a lot of lines (in the terminal window) saying something like gamma is not the last iop?

Using the offending photo, in darkroom, please click
compress history stack. Close darktable and open it again, select the offending photo. Still a problem?

Present darktable-git has a version number of 2.7.0+2112, I believe, which makes yours a trifle old. From where did you get your dt 2.7.0?

MfG
Claes in Lund, Schweden

I installed/compiled darktable from git master following the instructions on the dt website, just a few days ago

The other two questions, please?

MfG
Claes in Lund, Schweden

yes, I did all the things that you suggested, no change
in addition, I installed the newest git master version on a new (debian testing) system, still no change

this is a bug

Any reason to choose compiling instead of adding dev packages to your os?

I’m saying this because it’s much easier to keep your dev version up-to-date, instead of compiling each time they change the code (which is almost on a daily base).

Unless you want to dig deeper into debugging and sending dumps to the devs each time you face a bug.

1 Like

Well I filed a bug report and it was closed after 24 hours or so. My report was more or less ignored or not taken seriously.

Without a comment why it was closed?

there was a comment.