darktable 3.0.0 released

The submit request hasn’t been accepted yet.

LLVM 9 could also be installed from here: https://apt.llvm.org/

I have made a script for compiling DT 3.0 on Ubuntu 19.10.
The script creates a VM using multipass, installs loads of packages in the VM and finally compiles DT 3.0.

A “darktable --version” gives this:
this is darktable 3.0.0
copyright © 2009-2019 johannes hanika
darktable-dev@lists.darktable.org

compile options:
bit depth is 64 bit
normal build
SSE2 optimized codepath enabled
OpenMP support enabled
OpenCL support enabled
Lua support enabled, API version 5.0.2
Colord support enabled
gPhoto2 support enabled
GraphicsMagick support enabled
OpenEXR support enabled

I have put the script on Github - feel free to use and improve :slight_smile:

The script is here: https://github.com/per2jensen/dt-on-ubuntu

3 Likes

29th Dec 2019,

Ubuntu update has
3.0.0-0dhor~bionic
from
http://ppa.launchpad.net/dhor/myway/ubuntu
which seems to run fine.

1 Like

On a bit of a side note, I still can’t find a donations link on the darktable website. Is there any way to donate? Yes it’s that time of the year again. :wink:

1 Like

https://www.paypal.me/Aurelienpierre from Got an image problem ? Go see the image doctor.

1 Like

Is it feasible to build Darktable 3 on Ubuntu 16.04?

I’d like to build from source so I can fiddle with and (eventually) contribute to Darktable (plus I’m very exited about v3 and there’s no way to get it for 16.04 that I’ve found yet) but I’m not ready to do a version upgrade of Ubuntu.

I’ve been working on building Darktable it but I keep running into dependencies with insufficient versions and currently I’m stuck on GTK3 (Darktable 3 seems to requires v3.22, but apparently installing that version from the gnome3-team ppa will break Ubuntu 16.04).

The Darktable website says the master branch is not available for versions of Ubuntu less then 18.04 “because of missing required packages in older distributions”. Is there any workaround for Ubuntu 16.04?

@Francis welcome! So far as I’m aware, you can’t build darktable on 16.04 using just ubuntu’s native packages.

You can:

  • Build it in a snap package
  • install the nix package manager and get it from there. I did this yesterday on 18.04
  • probably build it using docker or lxc with newer versions of ubuntu

Thanks for your prompt reply — and for the suggestion of the nix package manager!
I am extremely happy to report that I have successfully installed (though not built) dt3 on Ubuntu 16.04 and am now exploring the new possibilities!

Thanks to everyone who contributed to this splendid update of this already wonderful program!

I started development of my hack software on 16.04, and found myself compiling my own versions of the image format libraries because the distro versions were hobbled in some regard. It was a PITA to upgrade, but it made my development life a lot easier. If you’re going to develop, you should probably slog your way through and upgrade, on at least one machine…

no it is not. gtk3 is too old. you have to use snap/appimage or upgrade.

1 Like
2 Likes

Hi everyone. I am new here and I come from LR 6.14. I recently bought Nikon Z6 and I saw that “matrix” is not supported yet. Sorry for the stupid question but what does it mean?

For now I am using workflow NEF > Adobe DNG Converter 12 > DNG 7.1 and above > then import to something like LR 6.14. Is it ok? Or am I losing something with not using native NEF file from camera?

Thank you for your replay in advance.

Hi Martin, welcome to the forum. I also have a Z 6, for which I had to go get the “matrix” to use in my hack software. I got it from RawTherapee…

I don’t know how darktable store these things, but the “matrix” is s set of nine numbers that are used in the colorspace conversion between your camera’s ability to record the spectrum and what our oh-so-limited output devices can handle. Each camera model is measured to produce these nine numbers.

Here’s the Z 6’s entriy in RawTherapee’s configuration file:

{ // Quality C, only colour matrix and PDAF lines info
        "make_model" : "Nikon Z 6",
        "dcraw_matrix" : [8210, -2534, -683, -5355, 13338, 2212, -1143, 1929, 6464], // Adobe DNG Converter 11.1 Beta ColorMatrix2
        "pdaf_pattern" : [0, 12],
        "pdaf_offset" : 32
    }

dcraw_matrix is the relevant entry. Of note are the pdaf_* entries; RawTherapee will correct that PDAF banding thing you’ve probably heard about, if you run into it. I haven’t, yet.

Someone who knows how darktable configures such will have to pipe in about where to put those numbers.

Thanks for saving me a lot of time and tedium by confirming that dt development is incompatible with 16.04.

I try to keep the versions on all the machines that I use synchronized with the production server environment that I’m responsible for, so upgrading is a major project and I try to save time by leapfrogging LTS versions.

Which would you recommend between 18.04 and 19.10 if I was going to upgrade one machine for dt development?

I recommend 19.10. gcc is at 9.2.1, which seems to have pushed through a lot of deprecations. The foundational image libraries, jpeg, tiff, and png, are at current major versions.

Ah, you have a server you’re responsible for. I’ve got a VPS, LTS at 18.04, but that’s a very different application with almost no overlap in dependencies with my workstation. As long as they’re posting security updates for both, I’m not worried about the version difference…

Packages for 3.0.0 for several distributions are available under the following link:

https://software.opensuse.org/download.html?project=graphics:darktable&package=darktable

I followed the instructions for Fedora 31 but got the response:

Package darktable-2.6.3-2.fc31.x86_64 is already installed.

Inserting a:

dnf erase fedora

proved to be necessary

I know dnf is just horrible, that’s why I use zypper on Fedora. Try to install it with:

dnf install darktable --allowerasing --best