darktable 3.6.0 unofficial build with CR3 support (osx, win10)

OSX build 3.6.0 with preliminary CR3 support:

Win10 build 3.6.0 with preliminary CR3 support:

differences to the official build:

  • rawspeed with added preliminary cr3 support
  • uses a custom built exiv2 0.27.4
  • built and optimized for my system configuration, OSX build requires osx >= 10.15, no signed app

If you don’t need cr3 support, stay with the official packages. If you need native cr3 support then this is better then waiting until christmas :wink:
and as usual: don’t forget to backup … since you’ll be a guinea pig for the cr3 stuff :wink:


It seems to be working on Debian 10 with Wine/Playonlinux nicely and also 3.7.0 Windows 64 works fine with wine. Thank you very much!

You are probably better off using a native linux build though…

Maybe… Please let me know If there is deb pagades, app Image, snap or other way to install it to Debian 10 without worry about depencies and no need to compile it by self.

afaik there’s no prebuilt package with cr3 support.
You’d really better build it yourself for linux - you’ll get ways better performance.
If you are afraid of integration the cr3 stuff see Darktable and the .CR3 - #12 by MStraeten

To build a linux native version I use the following commands:

  1. cd Start in HOME folder
  2. git clone git://github.com/darktable-org/darktable.git Check out darktable HEAD (master) from git
  3. cd darktable Enter the newly created folder
  4. git submodule init; git submodule update
  5. cd src/external/rawspeed
  6. git config remote.origin.url https://github.com/cytrinox/rawspeed.git This corresponds to currently opened rawspeed CR3 pull request
  7. git fetch Start from instruction 7 if you are refreshing a previous build
  8. Edit ~/darktable/.gitmodules file and update rawspeed section to:
    [submodule “src/external/rawspeed”]
    path = src/external/rawspeed
    url = https://github.com/cytrinox/rawspeed.git
    branch = canon_cr3
    (required changes in bold)
  9. git submodule update --remote
  10. cd ~/darktable
  11. sudo mkdir build; cd build; cmake … ; make ; sudo make install This puts the darktable executable in folder /usr/local/bin
  12. Run the program with command /usr/local/bin/darktable

NOTE: this assumes you have all the compilers and source code for components, and have built/installed exiv2 0.27.4
Any corrections or improvements to this are welcome!

1 Like

Thanks about support. Debian 10 stable have no right sw versions and there can be issues with depencies. Windows version with Wine runs quite well with my old HP Z800 (12 x 2,93Ghz), but of course native installation would be best. I think to still wait official version (or appimage, flathub or snap image). But thanks about installation quide. Later, if official version is still missing, I might to try install this to first virtual machine and after that to my workstation.


I tried to compile it in Arch, but it gave me this error message:
error: ‘rsvg_handle_get_dimensions’ is deprecated: Use 'rsvg_handle_get_intrinsic_size_in_pixels' instead [-Werror=deprecated-declarations] 422 | rsvg_handle_get_dimensions(svg, &dimension); | ^~~~~~~~~~~~~~~~~~~~~~~~~~

It is the same error when I try to compile this arch package: http://aur.archlinux.org/packages/darktable-cr3

Thanks in advance.

Looks like a known issue with a fix in progress: https://github.com/darktable-org/darktable/pull/10026

1 Like

Thanks for the reference. I guess that I will wait for the fix. :slightly_smiling_face:

Update - This package worked: http://aur.archlinux.org/packages/darktable-cr3-git

1 Like