darktable and OpenCL on Mac Retina running bare metal Linux

Is anyone here able to confirm that darktable can utilize openCL running on a bare metal install of Linux on a Macbook pro retina (around 2016 model)?

I can run it in a virtual machine without opencl, but am considering wiping the Mac Os and going to a Linux install. Would like to know before wiping the drive and doing the install. Is a test off a bootable USB a valid way to check?

Thanks

I cannot answer your exact question, but my experience is that it is highly dependent on the video card and the specific video drivers.

Thanks, it has the Intel Iris Pro 1536mb graphics card. I tried darktable 3.0 on the native macOS, but had frequent crashes. Other than a few false alerts on export, dt ran better on the Linux VM machine.

The Intel openCL drivers are not great. darktable will probably always run better on Linux.

Some macbooks run Linux well, and some don’t. You have to do your research about hardware support.

1 Like

I’m going to wipe the drive and install Linux. My research over the past 6 months has been inconclusive, but running the Linux under the VM has been good. Only way too know for sure is to do it!

1 Like

You can boot into a live Linux environment and test things before you install to hardware. This is a good way to test driver support and such.

Or use SuperDuper/CarbonCopyCloner to make a disk image of the Mac so you can easily restore it.

1 Like

Finishing up the carbon copy clone now. May try the live boot first, see what it reveals. Thanks

No love for openCL with a Manjaro install. Installed a bunch of opencl drivers (the kitchen sink approach) got past the usual "can’ find libopencl stuff in the terminal window, and got to a segfault where dt won’t open at all. Will try another distro, or try again using the MacOS version of dt to see what happens.

So no luck on Mint either. Installed the latest dt version on macOS, openCl not enabled. Funny that opneCL is enabled in Photoshop. Oh well, might be time for a new laptop once I have someplace I can travel to!

The clinfo cli tool helped me a lot, at least as a quick check on whether the openCL is active. It’s a lot easier than debugging darktable.

So is this something to run on LInux or MacOS? Thanks

No luck with installing the intel-opencl driver package, although running dartable -d opencl got past the “no opencl lib warning” before closing with a segfault. Wonder if an appimage would solve this problem?

Unlikely, as it’d probably rely on the system’s openCL drivers.

Looks like the solution is a new laptop sometime down the road.

I think I can help :wink:
I use darktable on Manjaro as well. darktable 3.2.1 failed to start with a segfault due to the newest version of the package intel-graphics-compiler (1.0.4427). Downgrading the package to version 1.0.4361 solved the issue for me (as it is described here: https://github.com/darktable-org/darktable/issues/6003).

1 Like

Thanks, I’ll check it out.

Well, that got me past the segfault, but still no openCL working. Thanks for the help.

It might be a stupid bunch of questions, but… (consider it a little checklist):
Did you install all necessary drivers for OpenCL?
Did you perform a darktable-cltest in the commandline? What does it say?
Did you check the settings for OpenCL in the settings menu?

No question is stupid, but my answers often are.

I never know if I have installed all the drivers, as I don’t really know what is needed.
I threw the kitchen sink at this, and don’t know what I might need to further install.
Here’s the output of the darktable cl test:

darktable -d opencl

0.093223 [opencl_init] opencl related configuration options:
0.093284 [opencl_init]
0.093292 [opencl_init] opencl: 1
0.093298 [opencl_init] opencl_scheduling_profile: ‘default’
0.093304 [opencl_init] opencl_library: ‘’
0.093311 [opencl_init] opencl_memory_requirement: 768
0.093317 [opencl_init] opencl_memory_headroom: 400
0.093323 [opencl_init] opencl_device_priority: ‘/!0,///!0,*’
0.093347 [opencl_init] opencl_mandatory_timeout: 200
0.093354 [opencl_init] opencl_size_roundup: 16
0.093360 [opencl_init] opencl_async_pixelpipe: 0
0.093366 [opencl_init] opencl_synch_cache: active module
0.093372 [opencl_init] opencl_number_event_handles: 25
0.093378 [opencl_init] opencl_micro_nap: 1000
0.093384 [opencl_init] opencl_use_pinned_memory: 0
0.093392 [opencl_init] opencl_use_cpu_devices: 0
0.093398 [opencl_init] opencl_avoid_atomics: 0
0.093403 [opencl_init]
0.093657 [opencl_init] found opencl runtime library ‘libOpenCL’
0.093703 [opencl_init] opencl library ‘libOpenCL’ found on your system and loaded
0.197276 [opencl_init] found 1 platform
0.197345 [opencl_init] could not get device id size: -1
0.197355 [opencl_init] found 0 device
0.197361 [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
0.197367 [opencl_init] initial status of opencl enabled flag is OFF.

In the GUI, OpenCl is not activated (not available)

These are all tests on a Parallels Mac host, using a Manjaro Linux Gnome client.
I get the same results on a VMware Host or a Vbox host.

Running darktable on the Mac Catalina OS OpenCl is active. I have not done any testing of this version 3.2.1 on the Mac yet. Previously on darktable 3.0.1, I had so many crashes that I got more done using the Vbox install without OpenCl.

I’ll probably do some more testing on the MacOS native install and see if anything has improved. It’s one of life’s little mysteries !

Okay, I think we found the root of your problem. You are trying to use your iGPU in a virtual machine, afaik that won’t work hence OpenCL is deactivated.