darktable-chart and Spyderchekr .cht issue

I’ve been trying to profile my camera using darktable-chart and a Datacolor Spyderchekr. Unfortunately, the .cht file for this color checker that comes with Argyll has some issues which make the file unreadable to darktable-chart.
In particular, I’ve found that the newlines in the file were not inserted correctly, which made the file unreadable. I’ve fixed this and now the file can be opened (I’ve googled this and found a few other users having the same issue).

Nonetheless, another issue remains: darktable-chart cannot read from this .cht the Lab (reference) values:

As you can see from the screenshot, the fourth column is empty. I’ve tried other .cht files, and they all read correctly. It’s just this one that doesn’t.
I’ve tried going through it and tackling the issue, but I’ve had no luck.

Here is a copy of the .cht file: BOXES 49 F _ _ 62 49 1684 49 1684 1187 62 1187 D ALL ALL _ _ 1684 1187 0 0 - Pastebin.com

Does anyone know what could be wrong with it?

Thank you in advance for your assistance.

Just an update: I’ve managed to find the issue. The original .cht file contained two tab characters before the “EXPECTED XYZ 48” section . It was completely invisible to the eye, but it made the file unreadable to darktable-chart.
Here is the corrected file: BOXES 49 F _ _ 62 49 1684 49 1684 1187 62 1187 D ALL ALL _ _ 1684 1187 0 0 - Pastebin.com

Also I own Spydercheckr so this is interesting. Which tutorial did you follow?

I’m following these instructions here: Profiling a camera with darktable-chart
Also, this can be useful: Patch color definitions for Datacolor SpyderCheckr 48 - Christoph Bartneck, Ph.D.
They’re the lab values for the color checker.

Hope this helps!

EDIT: unfortunately, there seems to be another problem. The size of that .cht grid is wrong.

I can’t have the grid match the size of the boxes. I’ve tried with different images , I’ve corrected the perspective, but the problem seems to be caused by the .cht file itself. The size of the hinge seems to be recorded wrongly. I’ll read the .cht file documentation and try to understand how the measurement is expressed in the .cht syntax, hopefully I’ll be succesful…

EDIT 3: it was a silly mistake of mine. Here’s the final .cht code, which works and aligns perfectly:


I have files that work I will share them when I get home later…Also its been a while but you may need to create the pfm in landscape orientation to get it to work or portrait I can’t recall but your cht file will specify if its looking for 4x6 or 6x4…

Soon you will be able to approximate this inside darktable…little different approach but should result in somewhat the same result if you are matching to a color chart…if you are matching to a jpg that is different…


Once I had more time to look I could see that you had created 3 groups across the x plane…glad you got it to work…

Thank you so much for your answer! Initially, I did create 3 groups (as I found another user in a blog who did the same), however, in the end it wasn’t necessary, as recent versions of darktable-chart are able to find the grey column by themselves, and so the origianal groups did work.

And that is amazing, I did not know about this addition to the color calibration module! I’m really looking forward to 3.6, having a module that helps with this is going to be perfect.

Its not a full replacement as it really is a guided channel mixer setting but after the wb and input profile present the image it is a way to tweak the colors wrt to a color checker and make the match even closer. It works pretty well…it is certainly easy.

That’s not true of the actual ArgyllCMS SpyderChecker.cht file, so I’m not sure where you got the file.

Note that tabs are perfectly acceptable in the patch value lines, since the ArgyllCMS code uses an fscanf and a space in the format will match spaces and tabs. (I’ve no idea how darktable-chart goes about using a .cht file though.)

Note also that the values in the .cht file are NOT color reference values, they are patch recognition values.

You’re right, I checked again again the original file and I definitely wrote badly: it was two spaces, not two tab characters. Sorry!
And thank you for pointing out both points, I stand corrected. Perhaps then the issue lies within how darktable-chart parses the file?