Darktable disabled opencl - way to restart without rebooting ?

darktable
(Phil Smith) #1

Hello,

Darktable sometimes disables opencl when I’m editing in the light table with the message “darktable discovered problems with your opencl; disabling for this session”.

Other than rebooting, is there a quick way to re-enable opencl please ?

Logging out and and in again doesn’t help.

I’m on Ubuntu 18.04 with Darktable 2.6.1, although I’ve had the same problem with previous versions of Darktable so it’s not a new issue.

If it helps my opencl config is :
opencl=TRUE
opencl_async_pixelpipe=false
opencl_avoid_atomics=false
opencl_checksum=892165130
opencl_device_priority=/!0,//**
opencl_enable_markesteijn=true
opencl_library=
opencl_mandatory_timeout=200
opencl_memory_headroom=400
opencl_memory_requirement=768
opencl_micro_nap=1000
opencl_number_event_handles=25
opencl_omit_whitebalance=
opencl_scheduling_profile=very fast GPU
opencl_size_roundup=16
opencl_synch_cache=false
opencl_use_cpu_devices=false
opencl_use_pinned_memory=false

Thanks,

Phil

0 Likes

(Mica) #2

What GPU with which drivers? How did you install darktable?

0 Likes

(Phil Smith) #3

Apologies for missing the basics.

GeForce GTX 670/PCIe/SSE2

Nvidia driver 390 installed via Synaptic.

Darktable from http://ppa.launchpad.net/pmjdebruijn/darktable-release/ubuntu

0 Likes

(Alessandro Amato Del Monte (Aadm)) #4

I have in my aliases this command that I often have to use when waking the pc up from sleep mode:

alias startgpu="sudo rmmod nvidia_uvm; sudo modprobe nvidia_uvm"

I also have a GeForce graphic card with same drivers as you do, so the command above should work.

1 Like

(Phil Smith) #5

Alessandro - than you I will give this a go next time it disables

0 Likes

(Phil Smith) #6

This works brilliantly and was the exact solution I was after. Thank you very much.

0 Likes

#7

Besides you got a solution, I have a GTX1060 G1 and it performs better, when I refrain calling it a “very fast GPU”
Also your priorities look a bit wired, if I quick look from my mobile…

0 Likes

(Phil Smith) #8

Thanks for the feedback, I will try avoid calling it a “very fast GPU” and see if I notice a difference.

I think the priorities in this post haven’t formatted properly, which does make them look odd and very well spotted.

I’ve checked my darktablerc file and the pattern matches exactly to the default option in the Darktable manual.

0 Likes

#9

@Phil_Smith
actually I have had the same issues with that default setting copied to here and than the asterisk got interpretation from this markup formatting :slight_smile:
I should have remembered that. My bad :blush:

I made a mistake: once in the past I thought, GPUs have that many cores, so I called mine (multiple GPU) and that did not work well. Your “very fast GPU” may work out. Just try and compare… Maybe with option -d perf

0 Likes