darktable error reading Panasonic G95 raw files


I’ve recently bought a Panasonic G95 and whenever I try to open the Panasonic raw files in the darkroom module of darktable, the darkroom module opens, but just displays an error and closes after a few seconds.

There are two error messages:
-Failed to read white balance information from filename
-darktable could not load filename Switching to lighttable now.
please check the camera model that produced the image is supported in darktable.

This is darktable 4.2. I’ve tried it previously on versions 4.0.1 and 3.8 and gotten the same error. I’m running Windows 10.

The G95 is listed as supported, although it doesn’t look like the WB presets are supported yet. That’s fine, I’d be happy to set my own WB if I could get it to load.

Can anyone point me in the right direction?

Hi, and welcome! Seems to work just fine on G95 samples from RPU:

Hi, thanks for checking. That is interesting. I downloaded that RW2 file and it loads fine, so it only seems to be affecting my own G95 files. I’ve tried multiple files over the last few weeks and they all give me an error.

I wonder if there is something new in the latest Panasonic firmware updates that has changed since the samples from the repository were uploaded.

When I checked the log file, I found the following errors when loading my RAW files:
[temperature] failed to read camera white balance information from P1000071.RW2'! [temperature] Panasonic DC-G95D’ color matrix not found for image
[temperature] failed to read camera white balance information from P1000071.RW2'! [temperature] failed to read camera white balance information from P1000071.RW2’!
[colorin] could not find requested profile `standard color matrix’!

Either indeed the firmware changed something in the raw format, or your files are somehow otherwise corrupted.

Ignore the temperature/WB related messages for now, the failure presumably happens earlier… If you start from CLI using darktable -d all you should get even more info in the log - look for rawspeed related messages.

Feel free to also share a failing raw file, here (and RPU, with the note that it is failing and firmware version).

1 Like

Ok thanks, that information was very helpful. Looking at the log I see the following error:
RawSpeed:Unable to find camera in database: ‘Panasonic’ ‘DC-G95D’ ‘’
Please consider providing samples on https://raw.pixls.us/, thanks!
[rawspeed] (P1000071.RW2) bool rawspeed::RawDecoder::checkCameraSupported(const rawspeed::CameraMetaData*, const std::string&, const std::string&, const std::string&), line 170: Camera ‘Panasonic’ ‘DC-G95D’, mode ‘’ not supported, and not allowed to guess. Sorry.

So, what looks like is happening is I have the “new” G95D instead of the original G95 and rawspeed doesn’t recognize the G95D as supported.

From my understanding, the only difference between the G95 and G95D is better resolution for the rear LCD screen. Internally everything should be identical if I could just get darktable to recognize the G95D as a G95 model.

Ah, you can just an alias in cameras.xml, you’ll find other examples there.

Please upload a sample to RPU nonetheless.

1 Like

I created an alias in cameras.xml and also in the lensfun xml file. Not sure if lensfun was needed but wanted to make sure it picked up the various lenses.

I did upload a sample to RPU with the “G95D” model.

Thanks for your help!


Thank you for the sample!

1 Like