darktable for Windows

windows
darktable

(Mike) #181

I was so happy to have tried to recently do my first export using DT for Win! Unfortunately, I noticed that only a portion of the primary watermark I use was exported together with my photos. I use a SVG file that has both an image and text. The text portion doesn’t get fully included in the exported image. Has anyone experienced this, too?

So far I’ve tried re-inkscaping (no expert here) the SVG file and used different fonts for the text, but that only creates either a filled black box or have the text too spaced out on where the text is supposed to be :frowning:

Any helpful ideas (or theories) appreciated, thanks!

Win_10 Intel_i5 8GB_RAM


(Mica) #182

You can try making your font an outline in inkscape.


#183

Hi guys,

sorry for this rather late reply. I only have found time to re-emerge out of submarine mode now.
After compiling git master I tried to proceed with noise profiling my D7500. At the end of the gen-profile I always received an error message, but a presets.json file and pdf files were created. So I manually copied the settings into noiseprofiles.json. After thisI tested my profile the last few weeks quite successfully and found out, that it works slightly better than using Ari El’s D500 profile (same sensor as D7500). i used tried it out on about a 100 pictures at ISO 3200 and on half a dozen ISO 2000 pictures. I am happy with it.D7500NPN.7z (6.5 MB)


#184

This is yet another snapshot installer that should fix the bug with exporting. When selecting a path in the file chooser it will now escape all \ characters. Please give it a try.

Installer: (please use the link from the 1st post)
PGP signature: https://pixls.us/files/darktable-2.3.0%2B1024~gec24c9282-win64.exe.asc
sha256sum: 50b2c9e03f27ccedec197ebe060bd15b3fe65f954138b7977e00926a209f75cf


(Ger Siemerink) #185

works fine now, thanks!!!


(Ingo Weyrich) #186

@houz

We had a similiar issue about comma (decimal point) separators in Rawtherapee long ago.

Calling

setlocale (LC_NUMERIC, "C"); // to set decimal point to "."

before reading (interpreting) the data, solved the issue


#187

I’d prefer to fix this properly. Unfortunately I can’t reproduce. I tried setting my locale settings in the Windows preferences to French, I tried setting LC_NUMERIC=fr, nothing triggered the bug when opening the Newark JPG.

@csierra02: Do you have a build environment set up to compile darktable on Windows? Otherwise I would provide you a test compile that has a bunch of debug outputs to maybe track down where it fails.


#188

I think I remember something similar being reported a while ago. I thought we fixed it. Could you please take a screenshot and upload it here?


#189

Hi houz

It’s strange that you can’t reproduce. I got the bug as I had a French default windows setting AND DT language : French
If you loose one of these two conditions either Windows, either DT language, the bug disappears.

To be able to test both the french DT and the english one, I tried to install DT twice, one in French and one in English in two separate folders at the root of my C harddisk. And also two separate folders for the pictures… This did no work. Went back with one installation with the two folders. I got mixed results, as soon as I open the picture with Dt in French, I do also have the bug as I open the other folder with DT set to English… So the parameters of the picture are not only written to the xmp sidecar file but also within DT
I am finally left to DT in English.

No I don’t have a compile environment. I am not an IT guy only a non professional photographer…


#190

What happens when you import the image in an English darktable (so everything is correct), close darktable and open it in French? Where does the map put your image? The right place?


#191

At the right place.


#192

So it seems to be indeed the reading of the file and not the subsequent display on the map.

I’ll try to make a debug build tomorrow, maybe that will tell us what’s going on.


#193

Please install this new snapshot installer. Ontop of the sources in git I also added some debug prints when importing images with GPS coordinates.

Installer: https://pixls.us/files/darktable-2.3.0%2B1049~g909d17612-dirty-win64.exe
PGP signature: https://pixls.us/files/darktable-2.3.0%2B1049~g909d17612-dirty-win64.exe.asc
sha256sum: e3a1db9ec07c772f3df1dc8e99a662a392a830690c6c4a4854ab1c43727a6b9e

Changes since the last build:

Bugfixes

  • Put libtiff errors to stderr, not popups
  • Show images in subfolders in collect’s folder mode
  • Properly sort folders for tree view in collect
  • Fix #11809: Restore mask channel in haze removal
  • opencl: fix bug #11802
  • A few issues with print mode

Updated translations

  • Dutch
  • French

#194

Salut @csierra02, Abends, @houz!

If I remember it correctly, Windows has f-i-v-e different major FR settings (Belgium, Canada, France, Luxembourg, Switzerland) plus e-i-g-h-t minor ones (Cameroon, Congo, Côte d’Ivoire, Mali, Monaco, Morocco, Senegal, West Indies), i.e. 13 different settings for one parameter or more.

Would DT recognize them all or could this be the reason for the non-correct interpretation?

@csierra02: exactly which FR setting do you use?

Have fun!
Claes in Lund, Sweden


#195

@Claes I suppose there will always be regional differences. We just need to be aware of language conventions that actually interfere with the programming efforts of our dear (grumpy) devs.


#196

Hi @afre,

Yes - but some of those 13 FR varieties do differ in the way they expect dates to be formatted and what decimal separator to expect…

I learnt it the hard way when writing bespoke software for an International group of companies :sob:


#197

That is why I used the vague term conventions. Look no further than conventions within a country. Even then, people can’t decide how to format their date and time.


#198

ok. this evening

-------- Message d’origine --------


#199

hi houz… quite busy today and the two coming days. Will handle on saturday


(Marcin) #200

Cool, mask working now with haze removal :smiley: