darktable for Windows

windows
darktable

#141

I looked closer at the bug and now understand why it happens.
The longitude of Lisbon is 9° W and DT has imported it as 9° Eexif_LRexif_DT


#142

We would need such an image to test and reproduce.


#143

What do you need ? xmp file or raw + xmp ?
The raw is quite heavy…do you have a site where I can upload it ?


(Mica) #144

https://filebin.net


darktable and LR/Fast Raw Viewer XMP Files
#145

As the geolocation seems to be included in your raw file (I hope you didn’t break it while adding that info!) we will need the raw file.


#146

Actually there are some cameras that have a GPS sensor and capture the
geolicalisation data in the file. My Canon 80D does not have this feature
so the gps data have been added after by a software and must be in the xmp
file. The Raw file is not modified after the shot. But I can send you the
raw as well, it is heavy, about 25 MB.
No I did not breake anything ;-), I am doing my tests on a copy of the raw
files :wink:


#147

In that case the XMP would be enough. Just make sure it’s the version as output by your GPS tagging application without having darktable touch it.


#148

Hi Tobias

Attached the genuine xmp file

20161231_51170_Lisbonne.xmp (3.48 KB)


#149

That XMP has the coordinates 38,41.8671666667N / 9,12.372W which are also read in darktable for me. I can’t confirm any error there.


(Tobias) #150

Perheps it is a problem with the language settings. Or a combination of the raw image and the xmp. Perhaps you can upload the raw file too.


#151

Can I change the langage settings after the installaltion or do I need to un install and install an english language copy ?
If the issue is with the langage settings there is a bug in Darktable with the French version.
I don’t think the raw file is the problem as other files present the issue too… Cap Vert longitude becomes Egyptian longitude…
I tried to uploaded the raw file but got an error… the file must be to big.


#152

I tried with a French dt and couldn’t reproduce either. You can change the language by starting darktable with --conf ui_last/gui_language=C from a cmd.exe or by appending it to the command in a shortcut link thing from your desktop.

If the raw is just 25 MB you can probably just upload it here.


#153

I believe it has nothing to do with dt’s language setting, I have another suspect: Windows regional settings. @csierra02 & @houz: what is your regional setting in Windows?

You can find them on Windows 10: Windows Settings/Time & Language/Region & Language, or at the Control Panel/Clock, Language, and Region/Region/Change date, time or number format/Additional Settings and check which setting is used, especially interesting would be the “Decimal symbol” and “Digit Grouping symbol”. I have a feeling that this influences how a decimal number found in an XMP text file is being interpreted by glib


#154

I am using the standard German settings on Windows 7. However, I don’t expect those to be related. If you look at the code you will see that all we do is either working on strings or using functions which explicitly don’t take the locale settings into account:

Unless of course exiv2 is doing something stupid, like translating the direction characters.


#155

Hi peterbud, thanks for your suggestion. I could not find these settings
under Windows10. I do have settings relative to
the date format, calendar… I know that these settings were defined in some
application programs such as Excel but I
don’t remember having seen them also in the OS


#156

I guess you are right. Actually if I see the screen capture from @csierra02, the numerical values are correct. The only problem that 9,12.372W has been “converted” to 9,12.372E


#157

Click on the left “Region et langue” and there should be something in French for “Related settings”. But if you start a Control Panel it might be easier


#158

Hi houz

What build od dt are your using ? I have 2.3.0+866 ~gc23bd4a5a

Rather than trying to upload again the raw file (yesterday the upload progressed regularly up to 100 %). At this point the command reply become available and I got the message : there has been an error. I supect that the forum has some size limit put on the files and these are checked only when you try to finalize the post…

Rather than trying again on a raw file, I had the idea to test dt on a jpg file taken at Newark. There is no xmp file along with the jpg, the GPS cordinates were put by LR afterwards the shot.

I first thought, aha, there is no longer a bug… But actually there is.
There is no longer a simple W / E change but there is a shift of the cordinates and the localisation in dt is several hundred of km away from the original location…

EXIF_dt2017-10-27_120115MAP


#159

Attached the jpg file… the was no xmp file, the GPS info is in the jpg

20040324GMT (5).JPG.xmp (3.1 KB)

I noticed that when the file is opened in dt, an xmp is created that collects the editing tasks done under dt

I upload it also for your investigations


#160

Hi peterbud and houz

Great ! After some searches, I was able to access these parameters. As suspected, the comma was defined as the decimal point separator. That is normal for French language but caused me already some problems in the past… data in txt format importations within XL.
So I changed to dot decimal point separator, restarted the computer, cleaned dt folder and copied new copies of the test files.
And as shown on the pictures, the problem is fixed.
Thank you for your help and suggestions.

us