darktable freezing

darktable

(-) #43

when opening darktable it slows down the computer performance, but doesn’t completely freeze. same with clicking on any image. it lags, but still does it’s thing. what completely freezes it is either right clicking on the detail slider and adjusting it with these lines or changing sliders to 0 in local contrast rapidly. sometimes it doesn’t freeze if i wait after adjusting the slider and then adjust the next. but it’s still lagging.
from the moment i open darktable everything is lagging. some of the actions, make it freeze completely. and it’s different every time.
i don’t know whether it’s setting sliders 0 or from going from slider to slider without waiting for some time or something else.
it still allows me to click and adjust the different tools after freezing, but at that moment the image doesn’t change and has a “working…” sign on it.


#44

About the freezing I have no idea, we have to pull in some darktable devs here. @houz, @LebedevRI, @hanatos, any idea?

That darktable is much slower on OSX than on other operating systems is something I already heared several times. Don’t know if this is generally the case and if there is much of a chance for improvement unless some OSX experienced devs join the project …


(Roman Lebedev) #45

I don’t develop/use darktable anymore nowadays, so i won’t be of any help, sorry.

What i can tell is that i don’t think you stated your hardware specs in here.
You need lots of memory (8GB+).
Since it’s mac, you most likely want to disable opencl.

But yeah, even with optimal hardware, uhm, how to spell that best,
some internal implemenation details are, suboptimal. It’s just sluggish.


(Hevii Guy) #46

I don’t think that this is a general Mac OS issue. I don’t experience the same problem at all. In fact, my box runs dt much faster than a colleague’s Wyndoze box does :sunglasses:

Here are my 10.11.6 system particulars:

Model Name: MacBook Pro
Model Identifier: MacBookPro11,1
Processor Name: Intel Core i5
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 8 GB

(-) #47

when i open darktable with

[/Applications/darktable.app/Contents/MacOS/darktable -d all --configdir ~/Desktop/test-database]

it works almost the same as before freezing every time. the only thing that make it freeze again is moving coarseness slider in local contrast to 1 or 2. if i put it to 2 it freezes for a bit and then comes back. when i put it to 1 it either does the same as with 2, but for a little longer or crashes. the lower the number, the more the freezing?
try it on your darktable, if you have it. try it few times.

when i open darktable from the applications folder, it’s buggy and freezing and lagging from the get-go


(-) #48

what do i do to disable it?


(-) #49

Version: 10.11.6
iMac: (21.5-inch, Late 2012)
Processor: 2.7 GHz Intel Core i5
Memory: 8 GB 1600 MHz DDR3
Graphics: NVIDIA GeForce GT 640M 512 MB
Serial Number: C02K97N8DNCR


#50

Not too hard to find: https://www.google.com/search?q=darktable+disable+opencl


(-) #51

still the same


(Tobias) #52

Just out of curiosity, what are you using now?


(Roman Lebedev) #53

Uhm, i just kinda don’t.