Darktable Lens correction module for Fujinon 23mm F2 WR

darktable
(Mica) #10

How about lensfun-update-data?

0 Likes

(Ruud Maas) #11

ruud@ruud-desktop:~$ sudo update-lensfun-db.
[sudo] wachtwoord voor ruud:
sudo: update-lensfun-db.: opdracht niet gevonden
ruud@ruud-desktop:~$ update-lensfun-db.
update-lensfun-db.: opdracht niet gevonden
ruud@ruud-desktop:~$

0 Likes

(Ruud Maas) #12

“opdracht niet gevonden” means command not find

0 Likes

#13

Try

sudo lensfun-update-data

as Mica suggested.
It works here, and I can now use your lens in my darktable.

There are many Linux distributions, and sometimes the commands are not identical :slight_smile:

0 Likes

(Ruud Maas) #14

Many thanks. Now it runs.
Super many thanks.
So for vignetting there aren nof contributions.
How can i help?
greetings.

0 Likes

(Mica) #15

See this section: Create lens calibration data for lensfun

0 Likes

(Ruud Maas) #16

Sorry, I do not fully understand your answer.
Is it correct that the lensd ata of mine fujinon XF 23mm F2 R WR is somehowe send to some user so everybody can use the corrections?
Greetings

0 Likes

(Ruud Maas) #17

Will look in to that. First need to getter some stuff
greetings

0 Likes

(Mica) #18

When you finish the vignetting procedure and have the vignette data for lensfun, it is good form to share that data with the lensfun project so everyone with that lens can have vignette correction.

0 Likes

(Ruud Maas) #19

Great initiative. As soon as I have the pics I will send them to Lensfun. I’ll inform You.
Greetings

0 Likes

(Ruud Maas) #20

Hi Mica, is a milky glass (for drinking of some kind) OK when i put that in front of the lens? I do not have any flat milky glass at my disposal.
greetings

0 Likes

(Mica) #21

probably not, the glass needs to be uniform in color and not have texture.

0 Likes

(Ruud Maas) #22

Hi Mica. Yesterday had things going wrong with the system. Now Iám back online with a fresh install of ubuntu 18.10. But same problem nu updated lensfun database. Also now the update with the command sudo lensfun-update-data does not function.
Which linux distro do you use so I get a distro that’s real good for Darktable.
Hope to hear from you.

0 Likes

#23

Morgen!

There are many good distros.
Previously, I used Ubuntu for many years
and never had any problems with RawTherapee,
darktable, or The Gimp.

Presently I am on Manjaro (which is a so called rolling distro,
always trying to serve you the latest versions).

I believe that Mica is on Debian stable. Or at least was:

In order to decide which distro works the best for you: why not
get a USB stick (with about 4 gig capacity), load it with a “live” distro,
boot from the USB and try it before you install it?

Have fun!
Claes in Lund, Zweden

0 Likes

(Ruud Maas) #24

Many thanks for the update . I’am going to test Manjaro and Antergos

0 Likes

(Ruud Maas) #25

Hi Claes,
Although one question. After installing Manjaro you only have to install darktable from official site and you get automatically the updated database from lensfun?

0 Likes

(Ruud Maas) #26

Hi Claes,
Sorry another question,
GIMP in Ubuntu 18.10 does not let Gḿic install somehow. Is this no problem with Manjaro?
Hope to hear from you.

0 Likes

#27

Ha! Do not be sorry! Questions can be fun [at least if I am able to come up with an educated reply :-)]

If you select the Live USB-method, you can test as many as you like.
I have never tried Antergos (at least not yet), so I can really only tell about my experience with Manjaro.

After installing Manjaro…

Why install it? Why not test using the Live USB-Manjaro?

No, you do not have to fetch darktable from official site.
You fetch it using Manjaro’s Package Manager.

Using the package manager, I can select if I want
RawTherapee 1:5.4-1 or RawTherapee-git (= nightly build).
darktable 2:2.4.4-2 or darktable-git (=nightly build).
gimp 2.10.8-1 or gimp-git.
gmic 2.4.1-1 (which works just fine with The Gimp).

I made the lensfun db update a few days ago using paperdigit’s terminal commands.

I’ll gladly answer more questions if I can help you, but I am going to be AFK for an hour or two…

MvG
Claes in Lund, Zweden

0 Likes

(Ruud Maas) #28

Hi Claes,
Thanks for the update. That package manager is what i’am missing in the new versions of ubuntu. It used to be there (years ago). They have changed that.
For me working with lybrea Office, Darktable and Gimp are the main applications. The rest is more internet based.
Important for me too is the setting of the brightness of the monitor. Something i realy miss in Ubuntu.
I’am goin to try Manjaro and let you know my experience.
Greetings

0 Likes

(Mica) #29

I am indeed on Debian Stable for my editing machine, but I use the flatpak of darktable, the appimage of gimp, and a few other apps in either flatpak or appimage.

0 Likes