Darktable Lua Script Manager

lua

(Bill Ferguson) #21

Fixed now, please download it again


(Hans Petter Birkeland) #22

I understand all that, but there is no new module. I have all the scripts installed, and I often use Edit in Gimp, the Hugin script and Enfuse Pro:
Normal

After installing Script_manager as described, my Lighttable view looks like this:

and there is also no Lua options tab in the Preferences.


#23

Please check with ‘darktable -d lua’ if it crashes.


(Bill Ferguson) #24

Okay, let’s try it this way

open a terminal, then copy and paste the following commands

cd /tmp
git clone https://github.com/wpferguson/script-manager.git
cd script-manager
cp script-manager.lua ~/.config/darktable/luarc

that should get it installed, then…

cd $HOME
darktable -d lua

that will run darktable and spit out any lua debugging messages to the terminal. If you don’t have the script_manager module, the output should tell us a reason why

Bill


(Hans Petter Birkeland) #25

Hm, that worked! Previously I didn’t use git, I just downloaded script_manager.lua manually. I tried using git yesterday but I messed up something, because I don’t use it regularly and I tried following the step by step instructions I used for installing all the other scripts. So that is what I mean by teaspoon instructions :slight_smile:.

Thanks a lot for your patience!


#26

Now it works. Thank you very much for this nice script.


(Martin Scharnke) #27

Thanks, Bill, for the step-by-step instructions; also working for me. :smile: