darktable newbie

Thanks Tim (I didn’t want to speak on behalf of the admins :slight_smile: ).

So I loaded the picture into darktable 3.2, using the default scene-referred/filmic workflow, and I didn’t see a bit problem with the colour balance using the default camera-provided settings in the raw file, around 4700K. I tried doing a spot whitebalance, and got very similar parameters to what the camera provided. When I selected the “Cloudy” preset, the picture looked very warm I thought.

I then wondered if you are using base curve rather than filmic, so I tried selecting the Nikon basecurve, and the picture didn’t look so nice, it was a bit bright and harsh. I’m wondering if that may be what you found objectionable?


If we are talking color cast, I must ask, is your monitor calibrated? And are all your applications using the same display profile?

1 Like

That’s a good point — my screen is colour-managed, but I don’t know about OP’s…

@Matt_Maguire , yes, my darktable is using the base curve. I am so new at this, could you give me a quick explanation of how to use your scene-referred/filmic workflow and get rid of the base curve? I would even be satisfied with a pointer to documentation on doing it. Every “new” raw file I open has the case curve already applied.

And @paperdigits, my monitors are not calibrated. I will try to find some docs on doing that.

Thank you both for your assistance.

The gist of it is simply to disable Base Curve module and enable the Filmic RGB module :slight_smile: The default filmic preset actually does a decent job for most photos with a reasonable dynamic range.

For more info check out this video: https://youtu.be/zbPj_TqTF88?t=4426 It’s long but informative. The link will take you straight to an example towards the end, but feel free to go back to the beginning if you want all of the theory (maybe later).

1 Like


About setting defaults: In the preferences section (little wheel top right of the screen) you need to select the processing tab, from there you can set your preference for workflow defaults.

  1. scene-referred - the linear rgb way of doing things,
  2. display referred - the Lab way,
  3. none…

Option 1 auto sets exposure and filmic, option 2 sets base curve. They also set the module order (ignore that for now).

If you are willing to read and watch some linear workflow related material I would recommend the following:

The above three are here on pixls.us

Aurélien Pierre also made a set of, somewhat technical, videos that might interest you:

EDIT: Just realized that the above filmic video is for the “old” one. It does explain how it works and the basics, so I would give it a go. This next one is about the latest one:

For those images that already have the base curve applied: You can select all those in lighttable view and select discard history in the history stack module (on the right side). BE AWARE: This will remove all the edits made, not just the base curve!

I would advise you to get a better feeling what it is you want/need from darktable first and start making bigger changes once stuff starts to fall into place for you.


Thank you very much, @Jade_NL . Your first tip is a great help - I thought I was going to have to start each new image, back out the base curve, and apply the filmic module.

I really appreciate the pointers to the docs and tutorials. I need to understand what I’m doing, not just be told what to do.

Here are some samples of what I just did before getting your tips. I think the second one is technically better, but I prefer the first one. I suppose I just like “warmth”. :wink:

1 Like

Here’s my thinking in that regard: Open your raw, then immediately select the Neutral profile at the top right. Then, you’ll be looking at the linear RGB data, with only white balance applied (if I’m missing something, RT users, please correct me) . This is the starting point for any tone manipulation, and instead of comparing alternatives, you’ll be thinking of it as what’s being done to the raw capture. That’ll be a much better basis for developing understanding of what’s going on…

1 Like

You probably missed that this is a darktable thread :wink:


Yes I did… cripes.

How does one start with neutral in Darktable, now that the processing chain is exposed… ???

@Tim W-e-l-l… If you prefer the warm development, then that is the best one. It is the one that you like that is the best.

Trying to find a neutral spot, to set the white point “correct”: how about placing the white balance module’s preset spot to the vertical white plank at the corner of the house? That would give you a temperature of about 5900K.

How does that look to you?

Have fun!
Claes in Lund, Sweden

1 Like

Turn off everything except demoasic, white balance, and orientation


Setting the ‘pixel workflow defaults’ to ‘None’ and disabling ‘auto-apply sharpen’ should give you this as a starting point for every photo, if you like.

This is a more difficult image to get a decent white balance. There are many small parts that look somewhat neutral, but there is a strong color fringing coming from the lens.
The small grey areas are overlapped by cyan and magenta, and much color noise.


That makes defining white balance with a color picker difficult. Your second example with the house and cars is much easier for that.

I would use the spot option from the white balance module and then use the color picker to take some color samples from a few neutral areas. After that I would fine-tune the white balance to get proper color values in the color picker’s areas.

1 Like

That’s CA. darktable has raw CA correction. Enabling it you should be able to get the same result as in my screenshot from RawTherapee (left without, right with raw CA correction) as it basically uses the same algorithm. The one in RT is a bit refined, but for the screenshot I used settings in RT to match the darktable version (though iirc in darktable it does (or did) not work well in preview, but in full processing it should work fine).

1 Like

Thanks, everyone. It is a cheap little camera with a pretty cheap lens. I guess that’s why all the color aberration.

Which can be corrected in post processing :wink:

1 Like

It does not show a processing tab, for me. Only GUI options, Core options, Session options, Shortcuts, and Presets. I have looked through all of those, and I do not see a place where I could select scene referred or display referred.

I am running the latest available release of darktable (3.0.2-7) on Arch Linux.

The scene-referred/display-referred setting is for darktable 3.2, which hasn’t been officially published yet. I think it should be available in the next few days, and it streamlines things a bit:

  • the “mid-grey” slider is removed from the new filmic in 3.2, since “exposure” module is now used instead. If you still have old filmic, just set mid-grey value to “18.45”
  • the new filmic sets the white point to +4EV, and black point to -8EV, which is a good starting point for a properly exposed picture (if the image is not properly exposed, use the “Exposure” module to compensate)
  • adding the “local contrast” module will often improve the image somewhat
  • if more colour saturation is required, this can be done with “colour balance” module, using the output saturation slider.
  • if you want to selectively tweak the exposure in parts of the image (eg. shadows, highlights, etc.) then tone equaliser works well.

Those are the primary modules I use now (and white balance, of course).


Yeah, my bad! Sorry.

I thought you used 3.2 or the latest development. Looking back I do not know where I got that idea…