darktable thumbnails

This is making me crazy. I don’t see the logic and behaviour for thumbnails creation/update in Darktable.

I used to do this: import bunch of photos, use darktabIe-generate-cache to create previews so that I can quickly make an edit in lighttable and decide what to keep, what to throw away. Then go do darkroom and do my processing on a few images. The thumbnail that is displayed in lighttable would then get updated and that’s the end of it.

I’m not sure when/why, but this is not working anymore and DT always insists on re-creating the thumbnails.

These are the options that I have now:

GUI Options:

  • Don’t use embedded jpegs but half-size raw: [checked]
  • high-quality thumb processing from size: WQXGA

Core options:

  • memory in mb to use for thumbnail cache: 4000
  • enable disk backend for thumbnail cache: [checked]
  • enable disk backend for full preview cache: [checked]

Please have a look at the attached screencast. It is only 1’30"; you will see me starting up darktable, then I select a photo in lighttable, hit my “sticky preview” shortcut on an image, wait until the image gets “rendered”, then move to another image, do the same, then return to the first image and the preview is not stored, so it has to be re-created! I repeat this process a few times. It should not do that, once a preview has been created why does it do it again and again? I’m pretty sure this wasnt’ the case a while ago but I may be wrong. I have played with the options above but now I don’t see the logic behind it all, because even if I unselect “Don’t use embedded jpegs” then I would expect to see a fast preview from the jpeg stored into the raw file, but in fact it’s the same as before!

As an additional note, I use that preview size (WQXGA) because my monitor is 2560x1440px. And I have 16Gb of ram.

thanks for any help!

I cannot play your Screencast

What distro do you use?
Did you try with a fresh ~/.config/dsrktable as well?

If you can’t see the screencast above watch it here: https://youtu.be/AVNYZEzFyFc

Which dt version? At least on my mobile I cannot see :blush:

latest git master (you can see the new UI by Aurelien just merged a few days ago), 2.7.0~git1007.2c0298e8

have not tried with brand new darktable config file however. Is there a way to make one from scratch? just delete or move the old one?

Ja, just move the directory. Later, ou may want to go back to have your library back.

You may also try 2.6.2…

I have at the moment some issues with 2.7’s performance as well…

Finally you may issue a bug report at [github] (https://github.com/darktable-org/darktable/issues).

I know @aurelienpierre did some optimization work to the way things get rendered in light table, perhaps this is related?

Am I right in thinking that sidecars from 2.7 are not compatible with 2.6.2?

They might be compatible, but that’d be coincidence. You should always treat them as incompatible.

actually they are incompatible, at least dt-2.6.2 do not accept them unless you fake 'em

So, just now I tried to reproduce here. (dt-2.7-1022)

When I leave darkroom back to lighttable, that particular image will get re-rendered in the thumbnail view.

  • To me it makes sense in a certain way.
  • Indeed one could check, it was with or without changes, and if no changes, then there is no reason to re-render.
  • But I can easily understand, that a software developer has more other reasons to say “I don’t know or I don’t want to know, whether or not changes might have happened (e.g. also just by new SW_version, even you do not touch any slider), so going out, I will re-render, no matter what”

Which Hardware you are on? (CPU, RAM, GPU)
Is opencl working propperly?

I didn’t touched the lighttable.

Thanks, sorry for the noise.

Tried to start with a brand new darktablerc: no changes. I can still see the preview being recomputed over and over again. Bear in mind I am not going to darkroom and make some changes, I’m only working on lighttable at the moment. Once again, see the screencast uploaded yesterday or the youtube link above.

OpenCL is working propertly, the computer is a Dell XPS15 with i7-7700HQ@2.80Ghz, 16Gb ram, Geforce GTX-1050. Ubuntu 18.10, darktable version 2.7.0~git1007.2c0298e8.

I have tried to reinstall 2.6.2 with an old library: this thing does not happen, when a full screen preview is computed then dismissed going back to the grid view then again recalled, DT instantly displays the high-quality preview.

I now believe this is a bug in current 2.7 from git. I will file a bug report on github.

In the meantime can I pick your brains on the thumbnail-related preferences mentioned at the beginning? I did ask already but I don’t fully understand the meaning of some of them. Or rather I can’t see any change in the desired outcome.

  • Don’t use embedded jpegs but half-size raw

…my understanding is that, if CHECKED, DT will calculate previews from raw file. First question: why “half-size” raw? This is rather confusing to me. Anyway, if I have it UNCHECKED I expect DT to load the embedded jpeg, right? But it doesn’t do that. At least in current git master. I mean I don’t see any difference between the two states.

Then:

  • high-quality thumb processing from size

If set to : WQXGA it means that every time there is a thumbanil greater than WQXGA (2560 × 1600 px) DT will compute a high-quality version from raw. Alright, but if I had set the previous option to use embedded jpegs, is this one applicable? Does it even make sense to have it activated? Maybe it should be greyed out just to avoid confusion?

Second related question: is this related only to thumbnails which are the little images that are displayed as grid of variable dimenions in lighttable, or also the “sticky preview” that I use to watch the image full screen from the preview?

1 Like

Filed in this issue:

1 Like

Thanks for reporting! Hope you get a resolution soon

I must say sorry, my reply actually does not fit. I should have looked more closely in order not to misunderstand… :blush:

Fortunately Pascal already took a bite :slight_smile: