Darktable "tiling failed for module 'atrous'. output may be garbled"

Hi,
I have completely wiped my disk (after an extensive backup of course) and now I have a clean and fresh setup of Ubuntu 18.04.2 Desktop LTS, and a freshly installed Darktable 2.6.2. I’m working on a HP Notebook with a 7 core 64 bit system and 8GB RAM. As soon as I want to export a selected raw file as a jpeg, Darktable immediately throws the error message “tiling failed for module ‘atrous’. output may be garbled” and crashes.
I haven’t really found much useful help online so far, but for a freshly installed software I find it odd to fail so miserably on the very first attempt to export already. Any suggestions?
Cheers

@Kevin_Klein Welcome to the forum. I did a quick search and found DT 2.4.0 taking a really long time to export jpgs.. Any relation to your issue?

Thanks. I’ve had the issue of exporting being slow before, but every since upgrading Ubuntu as well as Darktable, I can now not export at all due to this tiling error. I am assuming though that it has something to do with the new version requiring more resources.

How did you install 2.6.2? Do you have OpenCL enabled? A GPU?

I installed Darktable 2.6.2 via terminal: add PPA, update and install. I have a AMD Mars GPU, but haven’t installed OpenCL yet. Here are the specs:

kev@kev-HP-ProBook-470-G1:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M]

Is the new Darktable version really that reliant on the GPU device?

No not at all. You can turn OpenCL on and off completely in the settings.

Just wanted to eliminate it as a potential point of failure.

Can you do darktable -d all from the terminal, reproduce the crash and paste the terminal output here?

1 Like

Apologies for the late reply, it causes my whole system to freeze. I’ve only pasted the last part of the output, as the entire terminal output is huge… but let me know if you want to see the whole thing.

50.911782 [lighttable] expose took 0.0048 sec
[dev_pixelpipe] module orientation' min: (-0.008531; -0.008092; -0.010243) max: (0.439699; 0.489948; 0.596054) [export] 51.178249 [default_process_tiling_ptp] no need to use tiling for module 'basecurve' as no real memory saving to be expected 51.178255 [default_process_tiling_ptp] fall back to standard processing for module 'basecurve' 51.395390 [dev_pixelpipe] took 0.217 secs (1.544 CPU) processedbase curve’ on CPU with tiling, blended on CPU [export]
[dev_pixelpipe] module base curve' min: (0.000000; 0.000000; 0.000000) max: (0.737625; 0.790161; 0.872925) [export] 52.319954 [default_process_tiling_ptp] no need to use tiling for module 'colorin' as no real memory saving to be expected 52.319960 [default_process_tiling_ptp] fall back to standard processing for module 'colorin' 52.478022 [dev_pixelpipe] took 0.158 secs (1.177 CPU) processedinput color profile’ on CPU with tiling, blended on CPU [export]
[dev_pixelpipe] module input color profile' min: (-11.738577; -41.625336; -109.449684) max: (89.834732; 119.687958; 61.022961) [export] 53.401966 [default_process_tiling_ptp] no need to use tiling for module 'vibrance' as no real memory saving to be expected 53.401972 [default_process_tiling_ptp] fall back to standard processing for module 'vibrance' 53.619047 [dev_pixelpipe] took 0.217 secs (1.590 CPU) processedvibrance’ on CPU with tiling, blended on CPU [export]
[dev_pixelpipe] module `vibrance’ min: (-11.064738; -44.769482; -134.580978) max: (89.532799; 147.576035; 66.709007) [export]
54.545252 [default_process_tiling_ptp] gave up tiling for module ‘atrous’. too many tiles: 5520 x 8288
54.545292 [default_process_tiling_ptp] fall back to standard processing for module ‘atrous’
54.548844 [lighttable] image expose took 0.0009 sec
54.549636 [lighttable] image expose took 0.0008 sec
54.550433 [lighttable] image expose took 0.0008 sec
54.551272 [lighttable] image expose took 0.0008 sec
54.552129 [lighttable] image expose took 0.0008 sec
54.552824 [lighttable] image expose took 0.0007 sec
54.553555 [lighttable] image expose took 0.0007 sec
54.554236 [lighttable] image expose took 0.0007 sec
54.554897 [lighttable] image expose took 0.0007 sec
54.555570 [lighttable] image expose took 0.0007 sec
[mipmap_cache] thumbs fill 0.76/256.00 MB (0.30%)
[mipmap_cache] float fill 1/8 slots (12.50%)
[mipmap_cache] full fill 4/8 slots (50.00%)
[mipmap_cache] level | near match | miss | stand-in | fetches | total rq
[mipmap_cache] thumb | 23.22% | 23.22% | -nan% | 68.75% | 99.83%
[mipmap_cache] float | 50.00% | 50.00% | -nan% | 6.25% | 0.17%
[mipmap_cache] full | -nan% | -nan% | -nan% | 25.00% | 0.00%

54.555634 [lighttable] expose took 0.0081 sec
Killed

It seems that the issue is within the module ‘vibrance’, which gives up the tiling because the files are too big. I shoot with the Nikon D850, so the image resolution is 8288x 5520.

I also shoot a D850, but I’m using the flatpak on a machine with 32gb ram. I don’t see these issues. Do you have any special settings for the memory stuff in the preferences? If you rename your darktablerc file and try again, does anything change?

1 Like

I’m afraid renaming the darktablerc file did not help. As soon as I hit export, the whole system just freezes instantly and I can’t do anything… a nightmare.
No special settings were selected. The next problem is that because Darktable crashes, I can’t even start it even after system reboot, because the system thinks that a PID is still alive, and I get around this by deleting data.db, data.db.lock, and sometimes library.db and library.db.lock as well.
I did not have these issues on Ubuntu 16.04, even though the export was slow there too… I’m not even sure which Darktable version that was, but I think it was 2.4.0.
By the looks of it, this looks like a hardware related problem, and I guess I won’t get around upping my RAM… it looks like my machine is just not coping with the new Ubuntu and Darktable… even Gimp sometimes crashes when I’ve had it running for a while, and then simply want to close it later on after some inactivity.

Try raw files from #processing:playraw to see what happens.

Could be a firmware or driver issue.

1 Like