Darktable - too small characters on mac 27 inches


(charlie) #1

I use darktable 2.4 with macOS Sierra and 27 inches display, but I find that the characters are too small for my sight, even full screen.
I tried to edit the darktablerc configuration file, I managed to enlarge the two side panels with
panel_width = 500
but I can not enlarge the characters.
I tried to change with very different values:
Bauhaus / scale = 3.4
screen_dpi_overwrite = -1.0 (does not accept positive values, the interface is deformed)
screen_ppd_overwrite = -1.0 (does not accept positive values, the interface is deformed)
but without result.
Thank you.


(Daniel Catalina) #2

Check this thread for some solutions:


(charlie) #3

Thanks, I had already found this tip, but the file darktable.css does not exist on my mac, not even among the hidden files (I activated the option to make them visible). The file is not found by either Spotlight or EasyFind


(Daniel Catalina) #4

It should be within the app folder off darktable.

in Terminal go to a folder like: /Applications/darktable.app/Contents/MacOS/share. I am not sure this is the correct path, but if you google for ‘macos go to app path’ it should point you to the right direction.


(charlie) #5

I found darktable.css looking “at sight” in

/darktable.app/Contents/Resources/share/darktable/darktable.css

(why can not the other systems find it?).
I edited it and it works, thank you very much!


(Daniel Catalina) #6

If you run them with sudo you should find the file, otherwise thy do not have permissions to look in these folders.

You are welcome!


(charlie) #7

Thanks, I will take this into account for the next few occasions. Now I have solved, size 10 is the right one for me and for my eyes!
Thanks again.