darktable, Windows and Tethering


#1

Hi all,

I’m using dt 2.6.0 on Win7 and I can’t get it to see my camera.

I have a Canon 7D and Canon 400D. I can’t find anyway to unmount the cameras but I have used Zadig to install the winusb drivers. But still, dt doesn’t see my camera.

I tried with DslrDashboard, which also requires winusb, and it worked fine.

Is there anything else I can try?


(Pascal Obry) #2

Yes, motivate some more Windows developers. This is work and nothing come from free. At the moment we have a single dev on Windows, not nice when we see some many people using dt on this platform.


#3

Perhaps they would find a reason to transfer to Linux?


(Pascal Obry) #4

Yes :slight_smile: I think it is best to move away from Windows, but that’s still a long path :slight_smile:


(pphoto) #5

That’s true. Currently I am on a dualboot with Ubuntu and Windows 7. The amount of using Windows is decreasing but it will still get its time until I got rid of that…


#6

Brilliant! Thanks guys, that really helped.

Anyway…

It seems the problem is that gphoto2 can’t find it’s libs. Setting the environmental variables below solves this and the tethering now works.

CAMLIBS=C:\Program Files\darktable\lib\libgphoto2\2.5.21
IOLIBS=C:\Program Files\darktable\lib\libgphoto2_port\0.12.0


(Pascal Obry) #7

Probably worth adding an issue in GitHub for the Windows maintainer to add those settings during install if possible.


(darix) #8

Paging @peterbud and @Marcus_Meissner


(Bri) #9

If you’re not dead set on using darktable to tether I’ve just started using digiCamControl for Windows. Looks like it will support your cameras.


#10

I did look at digiCamControl but I like my software to be light on OS dependencies, preferably portable. digiCamControl uses the net framework so it’s not really for me.

Also, the real point of using darktable is that you can see a preview of the actual default processing you’re going to use. If not for this I may as well use canons eos utility or even just plug the camera into a tv.


#11

I thought it might be worth mentioning the session options tab in the settings. I found it a little quirky.

If you want to add paths then you need to use the ‘/’ forward slash (linux style) rather than the ‘\’ backslash (windows style).

You need to start the sub-directory with a ‘/’ forward slash otherwise the $(YEAR) variable is not expanded and the sub-directory string is concatenated to the base directory.


#12

You didn’t have CAMLIBS and IOLIBS set? That’s very strange, as those environment variables are set properly with the installer:


#13

Didn’t work for me. I’m using a batch file to set them and run dt so I still don’t have them in my registry.

Why not just set them from within the app? They don’t need to be global for anything else…


(Glenn Butcher) #14

They’re set to different values, depending on the operating system. Environment variables are the common mechanism across all OSs I know, so that lets the various package maintainers set them for their OS’s particulars.

If darktable were just a Windows program, having the app set them would be feasible. darktable started as a Linux application, and was only recently ported to Windows, and the developers now have to code so it works in all these places.


#15

I’m sure conditional code and strings are bread and butter for a project like this. And in this case I’d have thought it’d be very straight forward and simple.

Not that it matters, of course. It was just an idea…