darktable windows insider program 11/26

Here’s the link to the latest weekly build of darktable 4.5, darktable-4.5.0+1308~gb15765654a-win64.exe - Google Drive. The list of latest changes is at Comparing 39c3ce0e55…b15765654a darktable-org/darktable · GitHub

darktable is now at feature freeze. This build contains all the new features that will be in darktable 4.6. The only changes that will be merged from now on are bug fixes. The list of new features and other changes are at https://github.com/darktable-org/darktable/blob/master/RELEASE_NOTES.md


Thanks for the weekly build. The link for the release notes didn’t work for me.

1 Like

Thanks, fixed it…

1 Like

And the check :slight_smile: VirusTotal

1 Like

Heh, with this very version my humble Sigma lens became unrecognized, Sigma something *OR* Tamron something. Never happened in darktable before, but I know this dilemma from ExifTool, which does not distinguish between the two lenses. I see libimage-exiftool-perl \ in the list of changes, could this be somehow related?

        libimage-exiftool-perl \
     +  libfuse2 \
        libgdk-pixbuf2.0-dev \

That’s not a change. Only lines marked with - (removal) and + (addition) are changes; the other lines are just context.
These were exif-related changes (src/common/exif.cc and src/common/exif.h):

And this was their description: [imageio] [DAM] Hardcode the crop factor for the handful of cameras for which we can't calculate it correctly by victoryforce · Pull Request #15693 · darktable-org/darktable · GitHub

Maybe comment (ask) on that pull request, the developers should see it. @victoryforce , I think this came from you? Is this a red herring, or could it be related?

@kofa Don’t think that is related…

@wpferguson You haven’t bumped exiv2 to 0.28 by any chance when rebuilding your VM?

1 Like

No, these changes cannot affect it. Possible reasons are either that an older Lensfun lens database is packaged (unlikely to be the case, but in theory it’s a possible cause) or possibly darktable was built with an exiv2 version that has issues.

1 Like

I have compared Lensfun lens databases, since the previous dt weekly windows build, a single lens has been added, everything else is the same and well.

I built a new machine and thus a new build environment. The version of exiv2 is newer in the current build environment, so I’ll go back a version. IIRC there were problems with the current version.


Thank you, Bill! If useful, I can provide a sample cr2 file.

Be well!

Here’s a link to a version with the older exiv2 library, darktable-4.5.0+1308~gb15765654a-exiv-fix-win64.exe - Google Drive

1 Like

With this version, lens recognition works as expected again, @wpferguson, thank you for your time, have a good day!

@wpferguson : I just reported a bug/loop while testing this build. See Github

dt 4.5 loop when switching in darkroom between particular images from filmstrip #15771

Hi Bill, my issue #15771 seems to be solved in the latest nightly build: 4.5.0+1392~gb9edf6897a
Marc. So I CLOSED it.
Thank you for your support,

1 Like