darktable windows insider program 5/22

Here’s the link to the weekly snapshot of darktable 3.9, https://drive.google.com/file/d/1c3CUKCD7wabOU6ENUrCvBmPUahbC_SX8/view?usp=sharing. The latest changes can be viewed at Pulse · darktable-org/darktable · GitHub


Hmm… not sure what’s going on (seems OK for now) but just reporting this for “FYI” sake…

I installed this update (1568~gca7a55940) on Windows 11 Home and it abended when I tried to load an image from lighttable. Launched fine, but when I double-clicked to open the image in darkroom, poof and it was gone. No error dialog, nothing in the terminal, nothing in the event viewer, etc. Confirmed on more than one image (CR3).

I reinstalled last week’s 1505~g7ae3e79f4 and it worked fine. Then I realized I hadn’t tried 1568 with no darktablerc. So I reinstalled it, renamed my darktablerc and launched it. It fired up but then even moving it to another monitor caused it to die, more than once.

However, after restoring darktablerc’s name and launching a couple more times it’s run fine so far, but I’ll keep an eye on it.

As indicated, just passing this along in case it becomes relevant. Thanks.

Thanks for letting me know. I’ll test some here and see what happens

It crashes for me on importing photos. Don’t know about the last builds since I use stable. Just wanted to test if I could reproduce Lens error. It’s a fresh and clean install, no darktable folder from any previous version. No multimonitor setup, also tried open CL disabled. Please let me know, if you need more information.

Name der fehlerhaften Anwendung: darktable.exe, Version:, Zeitstempel: 0x00000000
Name des fehlerhaften Moduls: ntdll.dll, Version: 10.0.22000.653, Zeitstempel: 0xbaecbb56
Ausnahmecode: 0xc0000374
Fehleroffset: 0x000000000010c729
ID des fehlerhaften Prozesses: 0x313c
Startzeit der fehlerhaften Anwendung: 0x01d86e2b2b238505
Pfad der fehlerhaften Anwendung: C:\Program Files\darktable\bin\darktable.exe
Pfad des fehlerhaften Moduls: C:\Windows\SYSTEM32\ntdll.dll
Berichtskennung: 2936991c-3477-416d-b675-cb65e7a1da64
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

Here’s a log file from fresh install to import and crash.

darktable-log.txt (594.5 KB)

same here; windows 11; starting from command line briefly shows the interface, but then the application dies

Tested the weekly snapshot on Win 10 Pro and it works fine, including opening CR3 files.

I looked at the log file, but didn’t see anything that looked out of place. There was no backtrace from the crash, so there aren’t any clues as to what happened. I suggest opening an issue at Issues · darktable-org/darktable · GitHub

I tested my build on win 11 and i don’t have crashes either. Do both of you use dng files?

In my case this weeks darktable does not even start, it crashes instantly when opening.

capturing output when starting darktable shows the following:
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
[dt_pthread_create] info: bumping pthread’s stacksize from 0 to 2097152
Magick: Unrecognized image format () [No such file or directory].
[dt_imageio_large_thumbnail GM] thumbnail not found?

Going back to last weeks version I have no problem. I am a Pentax user, so yes, files I have are dng, however, created by camera.
Interestingly, when going back to last weeks version I see the same output, however, I can work with it. Changing options for opencl (very fast GPU instead default, or deactivating completely) allows the program to start; however, when opening a dng file it crashes.

There are some DNGs in my folder. I removed them and tried again. It only leads to the crash happing a little later. It completed importing 700 photos, but then crashed while scrolling through the lighttable. Now after starting it immediately crashes a second after the lighttable appeares.

I will have a look later, if noone is faster.

I just built 3.9.0+1568~gca7a55940 in debug w/ latest Msys2 (so GCC 12 and latest libs), and I can’t make it crash (Win 10 20H2 19042.1706 here).

(Started w/ a clean config folder and no sidecars, imported a couple of NEFs and a “problematic” DNG - no problems.)

FYI, I’m occasionally monitoring this topic, but am tied up now with no time to participate.


I tried a little stuff. In following order.

My normal photo folder with NEF, ARW, CR2 and some DNG (Adobe, DXO, Topaz) and all their corresponding XMP: Crash

New folder with first NEF, then NEF+ARW, then NEF+ARW+CR2, only raws, no XMP: each no crash

New folder with NEF, ARW, CR2 and DNG, only raws, no XMP: Crash

My normal photo folder with NEF, ARW, CR2 and their corresponding XMP: Crash

So there seems to be a problem with old edits and DNG.

Excuse my noobness, this means your version has that gdb backtrace stuff? I would test it if there is a chance for valuable output.

No DNGs for me just CR3s, but it was working at the last time I checked (away from my computer now).

Thanks for trying to narrow this down. Could be related to GainMap support introduced recently? @paolod

Sorry it’s not feasible to share my debug build…

I did a quick testing (just import my standard photo folder and scroll through the complete lighttable for building the previews) of 3.9.0+1468~g0e64b4646-win64 and 3.9.0+1505~g7ae3e79f4-win64. Both worked. So 3.9.0+1568~gca7a55940 seems to be the first one to crash.

Spoke too soon. 1568 imported a CR3 and CR2 OK, but when I tried to rotate the CR2 90 degrees CCW in lighttable it crashed and now won’t run. It fires up but the moment I see the lighttable screen it dies. I’m reverting to 1505 and will see how things go.

It is odd the amount of folks having issues. I’m not home for the rest of the week, so i can’t troubleshoot.

Could be but that was 2 weeks ago now so if the issue is more recent might not be that??