darktable, windows, Intel Iris and Opencl

Yet another thread about opencl. Since the other threads are a bit old now, and mostly focused on Linux I thought I’d start a new one just for windows.

So. I got a new laptop recently. An Acer Swift 3X with an i5 and Iris Xe Max graphics. I’ve installed dt 3.4 for now, and have gotten opencl working by following these steps - https://www.photo.buet.us/post/darktable-can-t-activate-opencl.

General speed is a lot faster than on my earlier desktop that had a 1050 ti. Exports are about 50% faster.

But as seen in the task manager, only one gpu is being used. Is there any way to enable use of both gpus?

0.973443 [opencl_init] opencl: 1
0.973443 [opencl_init] opencl_scheduling_profile: ‘multiple GPUs’
0.973443 [opencl_init] opencl_library: ‘’
0.973443 [opencl_init] opencl_memory_requirement: 768
0.973443 [opencl_init] opencl_memory_headroom: 400
0.973443 [opencl_init] opencl_device_priority: ‘/!0,///!0,*’

2.253248 [opencl_init] found 2 platforms
2.253248 [opencl_init] found 2 devices
2.253248 [opencl_init] device 0 Intel(R) Iris(R) Xe Graphics' supports image sizes of 16384 x 16384 2.253248 [opencl_init] device 0 Intel(R) Iris(R) Xe Graphics’ allows GPU memory allocations of up to 3235MB
[opencl_init] device 0: Intel(R) Iris(R) Xe Graphics
GLOBAL_MEM_SIZE: 6472MB
MAX_WORK_GROUP_SIZE: 256
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_ITEM_SIZES: [ 256 256 256 ]
DRIVER_VERSION: 27.20.100.9040
DEVICE_VERSION: OpenCL 3.0 NEO

2.396323 [opencl_init] device 1 Intel(R) Iris(R) Xe MAX Graphics' supports image sizes of 16384 x 16384 2.396323 [opencl_init] device 1 Intel(R) Iris(R) Xe MAX Graphics’ allows GPU memory allocations of up to 1569MB
[opencl_init] device 1: Intel(R) Iris(R) Xe MAX Graphics
GLOBAL_MEM_SIZE: 3139MB
MAX_WORK_GROUP_SIZE: 256
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_ITEM_SIZES: [ 256 256 256 ]
DRIVER_VERSION: 27.20.100.9040
DEVICE_VERSION: OpenCL 3.0 NEO

I think you need to edit opencl_device_priority in darktablerc. Have a look at the opencl chapter in the manual.

My device priority is set to /!0,///!0,* - that’s 5 different fields. The 3.4 manual only mentions 4 fields, viz center image, preview, export and thumbnail. Also, since there is no !1 anywhere, I guess the Xe Max gpu should be used. Need to do some more digging into this.

I think the 5th is for the second preview window, in case you put that on a second screen.
Something is wrong in your settings. Exclude the weaker GPU from processing the center image.

Note that darktable does not run the export queue in parallel, so only one picture is exported and one GPU is used at a time.

A better check of both GPUs working would be to do some heavy darkroom work while you export some pictures.

Ohh ok. Will test this further.