Darktable won't open

darktable

(Mica) #21

Can you make sure the lock files are deleted and reboot your system and try?


(Poul Daugbjerg) #22

I made sure that the lock files were removed (ls command), restarted Linux Mint and made sure again that the lock files were not there - and then double-clicked the darktable icon.
Something new happened:

  • the darktable icon appeared for short while in the bottom of the screen and disappeared again
  • nothing more happened - the darktable welcome screen did not appear and the ususal error message did not appear either
  • the ls command shows that the two lock files have been created again

(Mica) #23

It maybe sounds like your database was corrupted when darktable crashed or quit unexpectedly (hence the lock files still being there).

Can you make a backup of the whole ~/.var/app darktable directory, remove all the files, then try starting darktable again?


(Poul Daugbjerg) #24

Since I didn’t have a chance to really edit any images I don’t have any data to backup.
So I deinstalled Darktable and reinstalled it again. Nothing changed - Darktable wouldn’t start. Same error message.
I have installed Darktable on my Windows laptop and it seems to work perfectly, which surprises me, since Darktable originates from Linux.
As you my see I have given up. I am not a tech savy person and certainly not in Linux. And I guess Sisyphos will get his stone to the top of the mountain before I get Darktable to work in Linux.
Sorry for taking so much of your time without any rewarding result.


(Mica) #25

I think you must have some sort of corruption in the database(s) or settings files. The reason why things didn’t change when you reinstalled is because all the same settings and databases are still there, since those files are user data, they are not deleted when the application is uninstalled.

If you want to give it one more chance (I understand if you don’t!) then you have to remove the settings files for the darktable flatpak. They’re located in ~/.var/app/org.darktable.Darktable, so you’d need to issue the command rm -rf ~/.var/app/org.darktable.Darktable.

I’m here to help you, no need to apologize.


(Robert Stephan) #26

Only two questions, you’re running a 32.Bit system,the Darktable Flatpack is also 32 Bit?
And why don’t use the Version form the repository of your distribution?


(Mica) #27

Linux Mint ships flatpak by default in their software center, so it is likely this was installed “from the distribution.”


(Robert Stephan) #28

The remnants of my education forbid me to comment


(Mica) #29

I don’t understand your comment, sorry.


(Robert Stephan) #30

My opinion on Flatpack is here off topic. But I rather suspect a flaw in the flatpack creation than in darktable.