Darktable won't open

darktable

(Poul Daugbjerg) #1

I have just installed Linux Mint and Darktable on my Dell Vostro 1520 laptop and wa hoping to get to know Darktable for my raw processing. As you can understand I am new to both Linux and Darktable.
But Darktable won’t start. I get this message:
“an error has occurred while trying to open the database from
/home/poul/.var/app/org.Darktable/config/darktable/data.db
the database lock file contains a pid that seems to be alive in your system:2”
I have searched the existing discussions and found the advice to delete the lock files. But maybe because I am illiterate in Linux I haven’t been able to locate and delete the lock files.
Can anyone help?


(Mica) #2

The lock file is here: /home/poul/.var/app/org.Darktable/config/darktable/data.db.lock


(Poul Daugbjerg) #3

In a terminal window I wrote:
cd /home/poul/.var/app/org.Darktable/config/darktable/data.db.lock`
and got the answer:
bash: cd: /home/poul/.var/app/org.Darktable/config/darktable/data.db.lock: No such file or directory


#4

Hallojsa, Poul & velkommen!

On my distro (Manjaro), it is located here:

/home/claesl/.config/darktable/

A good old trick to find where a certain file is located is to run

sudo updatedb

followed by

locate data.db.lock

in your case.

Med venlig hilsen,
Claes fra Lund, i Sverige


(Poul Daugbjerg) #5

Hello Claes,

It worked, I found the data.db.lock file

Now, will this command delete the file:
delete /home/poul/…/darktable/data.db.lock ?


(Mica) #6

In a terminal do rm /home/poul/.var/app/org.Darktable/config/darktable/data.db.lock


#7

Skidegodt, Egon!

Please show the entire path (to be on the safe side).
Also, as Mica just wrote: it is rm (short for remove)
instead of delete in 'ux.

Med venlig hilsen,
Claes fra Lund i Sverige


(Mica) #8

@Claes, he is using the flatpak, which puts all config files in ~/.var/app.


#9

Ouch!!!


(Poul Daugbjerg) #10

I did the following:
poul@poul-Vostro-1520:~ sudo updatedb [sudo] password for poul: poul@poul-Vostro-1520:~ locate data.db.lock
/home/poul/.var/app/org.darktable.Darktable/config/darktable/data.db.lock
poul@poul-Vostro-1520:~ rm /home/poul/.var/app/org.darktable.Darktable/config/darktable/data.db.lock poul@poul-Vostro-1520:~ locate data.db.lock
/home/poul/.var/app/org.darktable.Darktable/config/darktable/data.db.lock

Please note that the data.db.lock seem bo be present even after the rm command

I also tried to start Darktable but it still refuses to start and still returns the same error message as before


(Mica) #11

Perhaps you want rm -rf /home/poul/.var/app/org.Darktable/config/darktable/data.db.lock

the -r is for recursive, and the -f is for force.


(Poul Daugbjerg) #12

OK, it seems that the lock file has been deleted. Now I get this response:

poul@poul-Vostro-1520:~ locate data.db.lock poul@poul-Vostro-1520:~

But Darktable still refuses to start and I get this error message:

“the database lock file contains a pid that seems to be alive in your system: 2”

Is it possibe that there are two lock files an I have only deleted one of them?


(Poul Daugbjerg) #13

I did this:

poul@poul-Vostro-1520:~ cd /home/poul/.var/app/org.darktable.Darktable/config/darktable poul@poul-Vostro-1520:~/.var/app/org.darktable.Darktable/config/darktable ls
data.db library.db library.db.lock
poul@poul-Vostro-1520:~/.var/app/org.darktable.Darktable/config/darktable$ rm -rf library.db.lock
poul@poul-Vostro-1520:~/.var/app/org.darktable.Darktable/config/darktable$ ls
data.db library.db
poul@poul-Vostro-1520:~/.var/app/org.darktable.Darktable/config/darktable$

So there was another lock file and I have deleted it as well

But still Darktable refuses to start and gives me the same error message as before

Should I give up and try a to install Darktable in windows in stead?


(Robert Stephan) #14

try

darktable -d control

at a terminal


(Poul Daugbjerg) #15

Hello RobertS,

It returns the reply:
darktable: command not found

Poul


(Robert Stephan) #16

Oh, I think there is no problem with Darktable, but in Flatpack. I’ve never used Flatpack, so I’m out of here.


(Mica) #17

You need to do flatpak run org.darktable.Darktable -d control


(Poul Daugbjerg) #18

I did the command and the reply was:
[defaults] found a 32-bit system with 4132596 kb ram and 2 cores (0 atom based)
[defaults] setting very conservative defaults
[init] the database lock file contains a pid that seems to be alive in your system: 2
[init] database is locked, probably another process is already using it
trying to open the images in the running instance


(Mica) #19

Are you issuing the rm command while darktable is running? If yes, please quit darktable and try and remove both library.db.lock and data.db.lock if they exist.


(Poul Daugbjerg) #20

I have quit darktable, removed library.db.loc and data.db.lock files (rm -rf command) and checked that the two files were in fact removed with the ls command, which they were.
Then I double-click the darktable icon. But again darktable won’t start and I get the same error message as before.
I issue the ls command and see that the two lock files are there again