DenoiseSharpen Filter is crashing Natron


(Daniel Hope) #1

Hello there
I’m new to this community so please excuse any errors in reporting and please feel free to put me right if so.

I’m trying to denoise a sequence of exrs (stop motion) using this plugin. I can hook it up in my comp now problem, and it will analyse the source without error. However, as soon as I try to display the result in the viewer Natron crashes, every time. I have tried it with other image sequences, stills, everything. Same result every time.

I’m using Natron 2.3.13
Many thanks in advance for your tips
Dan


(Daniel Hope) #2

UPDATE:

This only happens when the viewer is zoomed beyond 50%

The DenoiseSharpen node works fine, but when I zoom in the viewer to check the result, Natron crashes when the viewer gets past 50%


(Frédéric Devernay) #3

Which operating system?


(Daniel Hope) #4

I have tried in Windows 7 and Windows 10.

I’ve also now tried the latest snapshot and version 2.3.14

All have the same issue.

This exact issue was posted a couple of months ago here:

Sus-unn appeared to have it resolved by using the latest snapshot but I’m having no such luck here…

Many thanks
Dan


(Daniel Hope) #5

It is also slightly more stable with proxy mode enabled, but still not consistently stable.

I’m runnng on:

Xeon E5-2670 @2.6Ghz
32GB RAM
NVIDIA Geforce GTX 1070


(Frédéric Devernay) #6

I suspect that this is a Windows-only problem.
Within a few hours, there should be a new snapshot (dated aug 8) available from https://natron.fr/download/
Can you please test if it fixes it, and report in https://github.com/NatronGitHub/Natron/issues/300 ?


(Daniel Hope) #7

Thank you so much for the quick response.

I’m not seeing the snapshot yet, but will test it straight away when it’s there and post my findings.

Thanks again


(Frédéric Devernay) #8

For some reason the links don’t appear, but here they are:

https://downloads.natron.fr/Windows/snapshots/RB-2.3/64bit/files/Natron-RB-2.3-201808081849-f1d5182-Windows-x86_64bit-no-installer.zip
https://downloads.natron.fr/Windows/snapshots/RB-2.3/64bit/files/Natron-RB-2.3-201808081849-f1d5182-Windows-x86_64bit-setup.exe


(Daniel Hope) #9

It still crashes sadly.

Rather than hanging and getting a Windows crash report as happened before, Natron now just disappears without a trace.

So far I have only tested on Windows 10 but will try on Windows 7 when I get to my studio shortly.

Thanks


(Daniel Hope) #10

Same situation on Windows 7


(Omar Brown) #11

The denoise sharpen works on my setup Window10 and no crashes thus far.


(Frédéric Devernay) #12

It may depend on the number of cores of your machine, or on the number of threads used by Natron (in the preferences). Try lowering the number of threads in the preferences, maybe down to 1.
Windows is not the most stable platform for Natron, sorry.


(Frédéric Devernay) #13

you can also try rendering from the command-line


(Daniel Hope) #14

Unfortunately nothing seems to work here.

I have tried taking the render threads and the parallel renders down to 1, effects use the thread pool checked and max threads usable per effect to 1.

I also uninstalled all other versions of Natron, restored defaults on preferences and set Natron to use my intel graphics rather than the Nvidia.

Still no luck on windows 7 or 10.

@Blackvfx2018 would you mind sharing some details about your setup please.

Many thanks


(Omar Brown) #15

Sure!! What do you need to know.


(Daniel Hope) #16

Graphics card, ram processor, Windows version, that kind of thing.
Also which graphics card natron is using and if you have any plugins installed in nation.

It also would be interesting to know if you run any other software like Nuke for eg.

I’ve tried everything and the denoisesharpen consistently crashes my comps


(Omar Brown) #17

I am using a Dell laptop with an on-board Intel graphics card. I don’t have Nuke installed but I have Fusion. I have community PyPlugs installed and HitFilm free plugins.