digikam albums strange behaviour after timeshift

I have a bunch of albums in Digikam. They are all subdirs of my home:

I also have timeshift active on my system, which check every hour if a backup shoud be made or not. For that it seems to mount my home partition to /run/timeshift/backup:
But it doesn’t unmount it thereafter :frowning:

When in this situation I open digikam, my albumlist looks like so:

Is this normal behaviour?
I find this extremely irritating.
Can I do something about this? Or the digikam devs?

I’m on Linux mint 20.1 MATE, digikam 7.5 appimage

Why look at this from the digikam side and not the time shift side?

Because I haven’t noticed any impact of this mounting point in any other application.
Just would like to know if it’s expected behaviour, if others have noticed that, too.

Abends @RobertsDaughter,

I agree with @paperdigits, this phenomenon
is known among timeshift-people: timeshift "unmount" at DuckDuckGo

Claes in Lund, Schweden

For those who experience the same… this is why it happens and how to solve.
The database was created on my old PC. I had to get a new one and mirrored the files to that. Naturally, the UID was now different.
And each time timeshift was mounted that mountpoint was grabbed.
Now I saw that one can refresh the Album directories and voila - problem solved.

So no need to be angry about me asking why digicam does that (when it seems to be a timeshift problem).
Problem solved. Hope it helps others.