digiKam Will Not Open

I was using digiKam, version 7.3, when I went to perform a simple operation = the program froze and quit responding.

I waited a bit and finally used Task Manager to shut it down.

Waited a bit and clicked the TaskBar icon to reopen digiKam = little blue circle for a second and then nothing.

Tried to run as Administrator and same results.

Restarted machine several times and digiKam still refuses to open — however, although it does not show in Task Manager, when I attempt to uninstall it, I get a warning saying it is running.

Restart machine a couple times and then I can uninstall and then install.

I have tried fresh download of 7.6 = still refuses to open.

Uninstalled that and tried 6.4 = still will not open

Then, I completely manually picked out every vestige of digiKam from every nook and cranny, including the registry, - restarted the machine a few times - installed 7.6 again — and it still will not open.

When I attempt to open the program, it acts for about half a second like it may try and open and then no activity whatsoever.

I am at a loss.

How do I fix this ?

More Info:
In Task Manager, under Processes tab, there is a digiKam showing for each instance in which I have attempted to open the program.
I can right-click each instance and choose End Process.
However, no matter what I have tried, the program refuses to open.

I clicked on Showfoto and it opened immediately.
Tried digiKam again and no go.

As I already said, the program was working fine before it decided to quit.

You need to get us some sort of terminal output.

What do you need to know?
It is a Windows 7 machine.

I switched to another User and clicked to start digiKam — the digiKam brand-new-user dialogue immediately opened — I went through the new user process, accepting all of the default options.
When I got to the end of the new user dialogue and clicked Finish, exactly the same problem as with the original user = no response.

Can you start digikam from the terminal? Then post the output here. Also make sure virus scanner isn’t obstructing it.

This is a Windows 7 machine; what is the Windows equivalent of “terminal” ?
I have not been able to start digiKam by any means nor from any avenue available to me.
All other programs start and work fine.

I did find THIS

When I investigated all steps, the recommended value was already there EXCEPT for Step 6 ; in exefile — default, instead of the recommended "1" *, it says Application.

I did not change anything there yet as I wanted to make certain that I should.

You can use powershell or cmd.exe for a terminal on windows.

OKAY — Maybe getting somewhere – maybe.
I made another attempt at opening/starting the program, and as always, it didn’t do anything but create another invisible Process in Task Manager.

I got side-tracked into real life and was away from the computer for a couple hours.
When I came back, the TaskBar icon was lit up as if maybe we had something going on.
I moused over the icon and, lo and behold, digiKam was up and running; it was open to something I had been doing months ago, but it was open.

I navigated back to where I was when everything went haywire.
When it crashed, I had been making an attempt to add a “Collection”

Once again, I attempted to add the collection.
When I clicked Settings > Configure digiKam, nothing happened for the longest time and finally the dialogue appeared; likewise for each step in the process = make a selection and wait for ages before anything showed up.

It did finally finish the process of adding a Collection; so, I added another with the same results = each successive step in the process taking forever.

Other aspects of the program seem to work as well as they ever did.

So far, all my other programs seem to work fine.

I have not yet tried to see what will happen if I close the program and then attempt to start it again.

I can’t figure why this problem has remained through so many uninstalls and reinstalls and even after completely purging digiKam from the system.

After finally opening, it worked for a couple hours, keyword tagging several photos.

Then, it froze/crashed again.

Now, I am back to it not starting.

I tried starting from elevated Command Prompt with no success.

To make certain I was doing it correctly, I successfully opened other programs via Command Prompt; they opened instantaneously.

OK so how about the information that was originally asked for?

1 Like

I don’t know how to accomplish this.

Open one of the aforementioned terminals, drag the digicam exe file on to it, press Enter. Copy and paste that text here.

I have made numerous attempts at this and when I press Enter it just repeats the line of text that was already there:
as though I have done nothing.

I tried a couple other exe files with the same result.

This is what I am doing:
Window with Program Files>digiKam beside the elevated Command Prompt
I grab and drag the digiKam exe file onto the Command Prompt empty text space and release.
I then hit Enter

Okay; I don’t have any hair left to pull out…

I have learned that, if I click the Task Bar icon to open digiKam and just leave it alone, sometime within the next couple hours, it will just all of a sudden show up, ready for action — however, always opened to something I had done years ago.

Also, for no reason whatsoever, even with digiKam just there open but idle, I will get the notice "digiKam has stopped working; close the program.

All other programs = just click on the icon and WHAM! there they are — immediately.

After trying everything else, I got a brand-new SSD and cloned my O/S onto it and swapped them out.

The new SSD with the cloned O/S booted up immediately and everything was ready for action.

I gave it a bit to settle in and clicked the digiKam icon, fully expecting it to jump to life === what a frustrating disappointment === still sluggish and still has not opened.

I am at a loss.

I have numerous times manually picked every vestige of digiKam from the system — restart the machine several times === reinstall various versions of digiKam anew — and each and every one of them behaves as if I had made no attempt at all.

I really don’t want to have to reinstall Windows to get rid of this problem.

Try that, replacing firefox for digikam, should be the same in win7. Without logs nobody can help you. Reinstalling digikam or even windows should fix nothing as it isn’t an OS problem.

Thanks; I have already found that article and tried that a couple days ago with the same results = no digiKam.

Here is where I am now.

I used Macrium Reflect to replace my O/S with a system image I had created in April.

Once it had went through the motions and settled into Windows, the first thing I did was to click the digiKam icon (version 7.3 on this image); digiKam immediately jumped into action as quickly as it ever did.

As for getting logs via the Command Prompt, I closely followed the instructions and made several attempts and all it ever did was react as if I had done nothing.

Now that I seem to have things back in order, I will try the Command Prompt thing and see if it works for me now.

When this whole problem started, I was in the middle of adding a Collection and digiKam just froze up.

What really bewilders me is that, even after meticulously picking every particle of digiKam from the registry and every other hiding place in the system, as if it had never existed and then install digiKam and nothing at all had been fixed.

I appreciate everyone’s patience and help in this nightmare ordeal and I will update on whether it continues to behave or not.

Many thanks to everyone; I know I am not always the sharpest knife in the drawer when it comes to such matters and I appreciate everyone’s patience regardless.

1 Like

Glad it’s working out in the end :grin:

1 Like


I’m facing a similar problem with digiKam 8.3. I had to force close it using Task Manager due to not responding any more, and I am since unable to open digiKam. The background process is however running, consuming about 20% of CPU.

I have tried running it from PowerShell “start digikam.exe”, but this does not give any output in the console.

Does anyone have an idea how to proceed? Many thanks in advance!!