DNG files show skulls

darktable

#1

I’ve read through the common reasons for certain raw files showing up as skulls and won’t open. I’ve tried the suggested fixes/remedies. Nothing seems to work. The files in question were originally Pentax raw (pef) then converted to dng. I no longer have the pef version of these files. I have several, as in 100’s of dng files with this issue. Using Windows 10 and latest version of DT.

The other issue is that some of the dng files that display a thumbnail and can open, show white or black square block patterns as if some of the file information is missing. Are these corrupted in some way? I have no issues opening any of the dng files in RawTherapee or other programs.

Can anyone offer suggestions or a solution. Perhaps this will be addressed in the next version?

Thanks,
Charlie


(Mica) #2

Have you tried creating a fresh library.db and reimporting the files in question?


#3

Do you suggest deleting or renaming the .db file and then re-importing or a different method?


(Mica) #4

I wouldn’t suggest deleting it… move it to a different folder temporarily or rename it.


#5

I’ll try that. Thank you.


#6

I used your suggestion, but I get the same results. Not sure where I go from here.


(Mica) #7

Posting a problematic DMG file would be a good place to start.


(Kevin E) #8

I had a similar issue with some of my DNG files. I noted that some DNGs were fine, while others showed skulls. The Skull DNGs were all ones created by Lightroom. I opened them in PS and re-saved them (might have adjusted some save parameters, cannot remember) and then they worked fine. Perhaps there was some encoding method used that Adobe can read which dt cannot…

Not sure if this helps, but seemed similar to your issue.


#9

Thanks. I will do that soon if all else fails.


#10

Thanks Kevin. Did you do a batch export or just individual files?


(Kevin E) #11

I’m not sure what you mean. Let me explain further just in case there was some confusion:

THe DNG files I saw that had skulls were all generated by lightroom, specifically it’s built-in HDR or Panorama outputs. To alleviate the skulls in darktable I used windows explorer, navigated to the file in question, opened it in Photoshop, and resaved (possible changing setting in the save dialog, I cannot recall). So no exporting was involved.

I cannot recall, but I may have removed the files from darktable and then re-imported them, but I cannot recall for certain.


#12

Have you tried this on PS instead of LR? It might be LR’s problem or the scripts’.


#13

I don’t have PS but I do have PS Elements & Affinity photo. I will give one or both a try. Thank you all for the help and suggestions.


#14

I haven’t used PS or LR in a long time but PSE is definitely a neutered version and likely less feature rich or updated than LR. Based on what @BzKevin said, it sounds like it might be an Adobe issue.


#15

Maybe it is the same problem as shown here: https://discuss.pixls.us/t/darktable-unable-to-process-dng-from-panasonic-lx1/8025/22?u=luemmel