DT 3.6 output sharpening: GMIC executable not configured

DT 3.6.0-1 on Manjaro.

I’m trying to run: RL_out_sharp. It shows: started

But I run the export with the default settings, I get the following error:

GMIC executable not configured

I’m running:

$ pacman -Q gmic
gmic 2.9.7-5

What am I missing?


It means it can’t find gmic. How did you install dt?

I used pacman to install DT (community)

sudo pacman -S darktable

So this RL_out_sharp is an lua script. You probably need to go into Preferences > lua options > executable for GMic CLI and point it to where you have gmic installed on your system.


Pointed it to:


and now it works. Thank you.

I am the author of that script :wink:
In script manager, when you hover on the “RL_out_sharp started” (or any other script) it displays a tooltip with setup and usage instructions.

Hi, nice “meeting” you

I saw the help but … I didn’t notice the 2nd line of the usage section :frowning:

but this gave me the opportunity to tell how how thankful I am (not just to you but also to all the people that contributed to DT)

I am, to me the post sharpening is mandatory when i resize images (which is almost all the time). Without it, the resized images are so,so…

Thank you

Can this script be made to work with the Print module?

I am afraid not. That is out of reach of the lua api.
I leave the last word to @wpferguson

1 Like

At this time the darktable lua API does not work with the print module. The best we could do at this time is export the image and use the sharpening script, then import the result and print it with the print module

1 Like