dt 4.0 highlight reconstruction with guided laplacian

Is anyone else having trouble with highlight reconstruction using new Guided Laplacians option? If I use it with Filmic I just get lots of pink instead of reconstruction. Turn Filmic off (or use color science v5 instead of v6 in Filmic) and it works OK. Is highlight reconstruction not for use on the scene referred workflow?
The IMG_6799.CR3 file is the original. Highlight reconstruction expample.png is what the .CR3 file looks like with only the default modules and highlight reconstruction with Guided Laplacian on, and the .jpg is an example using Reconstruct Color rather than Laplacian.

Uploading: IMG_6799.CR3…

It could be helpful to know what are your setting. :slight_smile:

I think guided laplacian is designed primarily to reconstruct spotlights and specular reflections. So it might not be an adequate solution for the big surfaces in your photo. Otherwise I can’t help you with the HL-rec module, since I never get anything useful out of it. I only use the corresponding tab in filmic.

I am yet to have success with the guided laplacian option.

I’m far from an expert as I find the guided laplacians too slow… so I don’t use it much.
But there has been a couple of issues with dt setting the wrong white point on some cameras images. Which causes this kind of effect. The simplest way to correct that (from the highlight reconstruction perspective at least) is to lower the reconstruction threshold. Try it. Finally, have you tried different settings on the itereations slider and any other options? I have the impression that guided laplacions is one of those modules that needs adjusting - not just switching on and forgetting about :grinning:
Oh. and it is meant to work in scene-referred, but maybe not on large blown areas as mentioned already. Good luck.

I don’t think you uploaded the raw??

1 Like

Guided Laplacians are very much intended for a scene-referred workflow.
AP talks about it in this video: Filmic v6 and white balance interactions - YouTube

Guided laplacian is meant die very small areas , and you need (lots) of iterations for it to start working . It is NOT a simple ‘turn it on and done’ setting. For larger areas, you need to radius to be absurd high and iterations high , bringing even the fastest computers to their knees.

Use on of the other options , or wait for the new method in 4.2 (or get a test build with it compiled in ).

Filmic V5 desaturates highlights , causing there to be little to no color in very bright areas. So there hides the purple/pink look.

Filmic V6 with luminance Y chrominance-mode (or maybe ‘no’) has the same sort of effect (at least it often has for me ).

1 Like

Sharing the raw file would be great! From what i can see in the second image (that with the color cast) this will be some sort of challenge for any algorithm. You can only suppress the cast by current modules by some tricks but none of the modules is “really fit” to handle such cases really well.

This is not so much related to being in scene-refereed workflow or not, it’s just that supressing the cast must use different methods.

Would be nice to see how the new segmentation based hl recovery can handle this.

Exactly…I asked for the raw…hoping to see what it would do…

It looks like the OP did upload the raw or rather tried to - it’s stuck at ‘uploading’…

Sorry, I had thought the .CR3 had uploaded along with the two .jpg files. (It even says “Uploading: IMG_6799.CR3…” on a line between the two photos! Looks like it was rather slow uploading the file and I pressed GO before it had finished. It seems to have been successful here.
IMG_6799.CR3 (33.1 MB)

1 Like

‘reconstruct color’ seems to work well enough. But it is just a large blown-out portion, so don’t know what to make more of it.

IMG_6799.CR3.xmp (25.4 KB)

The usual: Load file with filmic, color calibration, highlight reconstruction disabled. Use exiftool to check what it reports as white level, and make sure Darktable uses the same value (which it does for me).
Reset white-balance to ‘as shot’. I do this since ‘color calibration’ and the modern color-workflow often doesn’t work for my Sony.

Lower exposure, so low that you see ‘room’ in the histogram…

…so you know you’re looking at everything. Now go toy with ‘highlight reconstruction’ to see what you get. But as I said, ‘reconstruct color’ seems to work well for me. I even raised the clipped-threshold, to just below where the purple is gone.

Then raise exposure to where it should be (ignoring any clipping! That’s for filmic to handle later).
Focus on shadows and mids.
What I see is a very weird black-level. I don’t see this often, but might be normal for your camera? Or just the scene…

So I adjust the black-level-correction till I think it’s where it should be.

Now enable filmic, and hit the ‘auto select white level’ thing to set it.

I enabled the vibrant-color preset in ‘color balance rgb’ to get some color going:

And enabled the ‘local contrast’ module at default settings.
In the xmp I posted I used the ‘tone equalizer’ to get the highlights a bit lower, but I don’t feel it did much.

I also used an earlier instance of local-contast in an extreme bilateral mode, masked for the highlights - to try to make some details more visible in the highlights.

Then enable lens correction /chromatics if you think it needs it, same for sharpening (I used some heavy diffuse).


IMG_6799.CR3.xmp (10.7 KB)

Could do with more work on the shadows perhaps and perhaps some masking…no masks used for this one…

I did use the new HLR mode (probably incorrectly :slight_smile: ) and changed the raw white point to a value I found in the metadata… Canon seems to have 2 values a specular one and something they call real white point??

I’ve notice with this image that my export and and lighttable previews seem to match. THe area alsong the left that was reconstructed is a bit of a smudge…but the preview in Darkroom view which I quite like had some definition and tone?? I am trying to reconcile this once again.

This is darkroom

and then Lighttable…similar to the export??

Obvioulsy I would like the export to match my display preview in darkroom view…

I will go over my settings again…


@hannoschwalm I will see if I can replicate this in another image but this seems only to be the case if I use the new segmentation. For others it seems to match, ie the preview in Lighttable and Darkroom match… not sure if this is a one off or it could in some way be explained. Could your new mode be fed to the darkroom preview and not the same way to the export and lightable pipelines??

I will see if I can replicate elsewhere…

1 Like

Yes it’s only with the “new mode” that tries to reconstruct data in allclipped regions. Please note, that this is simply optional and still under evaluation / testing.

NP on my end…just passing along an observation… I see you have a few more minor updates. I will update the Windows build when I get a chance…

It was quite a contrast. I really liked what I managed to stumble on with your code but then the export didn’t do it justice…

I will work on this for some final tunings and checks tomorrow, don’t waste your time. I’ll let you know.

Thank you guys, your help and explanations are really useful. At least I’m not missing something easy.

Well , you clipped the sensor and took the shot too bright. The easy thing is to not over expose so you don’t have to fix things during the edit :wink: .

That being said , the only thing you might have missed is 'you clipped you highlights , so you need to turn on highlight reconstruction '. And just flick through the options to see if something looks better.

Setting it to "reconstruct color ’ mode without touching any other settings will fix your problem.

Now , If you don’t like the results you might need to learn a bit. And of course there are more ways to fix this issue.

But the easiest thing - and for me logical , but I’m more an IT nerd than a photographer - is to try highlight reconstruction in it’s ‘lch’ mode or ‘reconstruct color’ mode. If one of the two does what you want , tadaah.

But still , not overexposing is step 1 :wink:.