Enable Arch/Manjaro opencl-amd in darktable

(made new account to unify usernames across various places I have accounts, previously @rtwx)

So I spent last night and this morning getting opencl support enabled in darktable; I added opencl-mesa from manjaro repo, but when I ran darktable -d opencl I got the following:

So… no good. worked out I needed ocl-icd by reading the Arch Wiki, but same result still.
I found some guides for adding the opencl bits from the amdgpu-pro package to the opensource driver in Ubuntu and Fedora, but not Manjaro.

I figured the AUR would be the answer, and eventually took a guess and installed opencl-amd and it worked!

Noticeable increase in speed, much closer to the speed of Lightroom on Windows. I usually process a few hundred images at a time from events, so loading time matters a lot to me. :smiley:

Here are the packages installed on my system for reference:

So yeah. Very happy now :grin:

3 Likes

You could’ve just changed your user name…

I couldn’t see a way to change it. Display name yes, but not login/username? oh well :laughing:

2 Likes

Voce pode usar o Rocm ou AMDGPU-PRO

ROCm

1 Like

Nice reference, thank you!

@darix that is no longer required with the opencl package from the AUR it seems.