Enable Verbose Output [Linux] [Appimage Hosts] [SOLVED!]

How do I enable G’MIC verbose output when used as a plugin in Gimp.appimage or Krita.appimage?

When I open Krita/Gimp from terminal, then open G’MIC within the application, I usually got some verbose output in the console which I could copy to create later on a batch processing command.

outputs in the terminal looked similar like this:
[gmic_gimp]./apply/ -v -99 -fx_bokeh 0,8,0,30,8,4,0.3,0.2,210,210,80,160,0.7,30,20,20,1,2,170,130,20,110,0.15,0

But I do not get any outputs at all on my recent Ubuntu 20.04.1 LTS with G’MIC.

Weird thing is that I have one computer where it works, on the others it does not work, so I guess its something simple like enabling a flag somewhere… but what exactly where, diging since 3 days, any help very appreciated…

Tried with gmic_krita_qt version from gmic.eu and with the gmic.appimage version from krita.org

only output I get in the console when loading GMIC:

gmic-qt: socket Key: "{fb41c4ce-fe25-4e81-a224-920e521ac486}"

(process:17093): Gtk-WARNING **: 22:36:30.409: Locale not supported by C library.
	Using the fallback 'C' locale.
QObject::startTimer: Timers cannot have negative intervals

Finally figured it out (as always after opening a post…)

  1. Open GMIC
  2. Click Settings
  3. Select “Other”
  4. Enable “Verbose (Console)”


If you read this thread and need the verbose output to do some batch processing of FX to an image sequence, here the lines:

this was the verbose output in terminal:

[gmic_krita_qt]./apply/ ms_nlmeans_c_noise2_p 3,1,0,0,0,0,0,10,2,4,2,7,0,0,0,0

which represents the wanted setting,to process this for all images in the folder, cd into to the folder and then (adjust .jpg if you have another file format):

for i in *.jpg; do echo $i; gmic $i -ms_nlmeans_c_noise2_p 3,1,0,0,0,0,0,10,2,4,2,7,0,0,0,0 -o gmic.processed.$i; done

and now its time to test this on the pinephone… :wink: