Enfuse in Darktable

Hi community,

I’m new here and hope somebody can help me.

I have a problem with den enfuse plugin in darktable.
I use Ubuntu 20.04 and installed darktable as a snap package. Then I tried to manage a image stacking of a few test shoots. So I installed and activated the enfuse and the hugin scripts.
The new entry appeared and I selected my pics and started the process. Then I got the message align_image_stack failed .

That’s what I tried till now. I installed darktable as an ubuntu package, cloned the git repo of the addons. Same message.
Then I tried the flatpack, but if I understood right the lua scripts doesn’t work with flatpack.
And I tried to install the snap package and cloned the scripts with git.
Always the same problem.

Does anyone have a tip for me?

Thank you.
Homer

The snap package is sandboxes and can’t run outside executables. It should work in the distro package. Have you installed enfuse?

Have you tried installing Hugin, and use that directly? That way you can see if there’s something with your images that causes the failure.

Hi,

@paperdigits Yes enfuse is installed. And the snap package has an other installation path in the home folder : ~/snap/darktable …
There I installed all lua scripts and the script manager can find them.
And with the version of the ubuntu repos I’ve the same problem.

@rvietor Hugin is installed and it’s working with my test pics.

I gave hugin, and on the command line align_image_stack and enfuse a chance.
Hugin is working.
align_image_stack is working.
enfuse is working, but I get the failure message picture has no alpha channel.

Thank you.

Hi,

I have trouble installing the enfuse lua scripts in darktable 3.1.

anna@anna-hppavilionlaptop14ce3xxx:~$ darktable -d lua
0,909456 LUA ERROR : /home/anna/.config/darktable/luarc:1: module 'official/enfu
no field package.preload[‘official/enfuse.lua’]
no file ‘/usr/local/share/lua/5.3/official/enfuse/lua.lua’
no file ‘/usr/local/share/lua/5.3/official/enfuse/lua/init.lua’
no file ‘/usr/local/lib/lua/5.3/official/enfuse/lua.lua’
no file ‘/usr/local/lib/lua/5.3/official/enfuse/lua/init.lua’
no file ‘/usr/share/lua/5.3/official/enfuse/lua.lua’
no file ‘/usr/share/lua/5.3/official/enfuse/lua/init.lua’
no file ‘./official/enfuse/lua.lua’
no file ‘./official/enfuse/lua/init.lua’
no file ‘/usr/share/darktable/lua/official/enfuse/lua.lua’
no file ‘/home/anna/.config/darktable/lua/official/enfuse/lua.lua’
no file ‘/usr/local/lib/lua/5.3/official/enfuse/lua.so’
no file ‘/usr/lib/x86_64-linux-gnu/lua/5.3/official/enfuse/lua.so’
no file ‘/usr/lib/lua/5.3/official/enfuse/lua.so’
no file ‘/usr/local/lib/lua/5.3/loadall.so’
no file ‘./official/enfuse/lua.so’
no file ‘/usr/local/lib/lua/5.3/official/enfuse.so’
no file ‘/usr/lib/x86_64-linux-gnu/lua/5.3/official/enfuse.so’
no file ‘/usr/lib/lua/5.3/official/enfuse.so’
no file ‘/usr/local/lib/lua/5.3/loadall.so’
no file ‘./official/enfuse.so’

This is my luarc

require “official/enfuse.lua”
require “official/yield.lua”
require “contrib/hugin.lua”
require “enfuseAdvanced.lua”

never mind, I fixed it but it still does not work for some other reason

anna@anna-hppavilionlaptop14ce3xxx:~$ darktable -d lua
0,792928 LUA found enfuse executable at ‘/home/anna’
sh: 1: /home/anna: Permission denied
0,793430 LUA ERROR : /home/anna/.config/darktable/lua/official/enfuse.lua:74: at

Did you try the luarc script from the lua package? On my system darktable found my scripts with that script after I renamed it. The self created luarc didn’t work on my system, neither the .deb version nor the snap.

what exactly do you mean? which lua package? what’s the file name?

The addons you installed are all combined in a collection named lua. I got this package by cloneing it from a git repo.


In this package is the script manager included. In the cloned files is a folder named tools, and there is a file named script_manager.lua .
If you cp this file to $HOME/.config/darktable/ and rename it to luarc the script manager will integrate all scripts to darktable.

So was my way, maybe you’ve another solution.

Homer

Ok, I think I was able to do that, but the enfuse options still don’t show up under “target storage”.

Did you enable enfuse in the script manager on the left side of darktable?

Thanks, that was the missing info. Howerver, I get this now when I am trying to run enfuseAdvanced:

sh: 1: /home/anna: Permission denied
rm: cannot remove ‘/tmp/aligned_0000.tif’: No such file or directory
rm: cannot remove ‘/tmp/aligned_0001.tif’: No such file or directory
rm: cannot remove ‘/tmp/aligned_0002.tif’: No such file or directory
168,110520 LUA ERROR align_image_stack failed

I don’t like that “permission denied”. Usually that means that either a file cannot be written or a script cannot be executed. And that might explain the messages about non-existing files.

Well can the temporary directory be changed somehow?

Not afaik, but /tmp should be writable for everyone (that’s the default afaik). But not seeing the files appear in /tmp doesn’t automatically mean that write access is the problem, if one of the scripts can’t execute (not marked as executable?) the files won’t be written either.

@betazoid Please try the following

In script_manager go to the tools category and enable executable manager

executable_manager will start in the bottom left. Open it and select align_image_stack from the drop down. I’m going to guess that it shows /home/anna for the executable path. Click the clear button to clear it out. You should probably do the same for enfuse.

Try exporting to enfuse again

1 Like

I did what you suggested but the result is the same. Well it seems to me that the clear path button does not do anything. The path that is shown does not change anyway.

Thanks for the hint, it helped to solve the problem in my case!

1 Like