Epsonscan2 on flatpak and Tumbleweed for B&W negatives scan

Does anyone managed to make epsonscan2 flatpak work on Tumbleweed and “see” their scanner (Locally via USB connection)?

I have an EPSON Perfection 4490 PHOTO scanner that iscan manages to detect via USB (as epkowa:interpreter:002:005) and scan successfully but the Epson’s software installed via the Software Centre on flatpak cannot. Note that before the flatpak installation I did have the same epsonscan2 program installed normally (not flatpaked) and had the same behaviour.

I have tried adding myself to the lp group, checking the /etc/sane.d/dll.conf for epson, epson2 and epkowa entries to be uncommented (epkowa was already withouth a hash in front) and scanimage -L returns the right devise. Also lsusb also returns in the list the scanner.

I need the epsonscan2 application so to be able to auto separate the 35mm film frames on the film. As I remember correctly the app interface does this automatically where in iscan one has to do that manually and it takes ages.

Can you start the flatpak from the command line and share the output?

markman8@pc-57:~> lsusb
Bus 001 Device 002: ID 8087:8001 Intel Corp. Integrated Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
Bus 002 Device 003: ID 138a:0017 Validity Sensors, Inc. VFS 5011 fingerprint sensor
Bus 002 Device 002: ID 04f3:012d Elan Microelectronics Corp. Touchscreen
Bus 002 Device 005: ID 04b8:0119 Seiko Epson Corp. GT-X750 [Perfection 4490 Photo]
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
markman8@pc-57:~> flatpak run net.
net.displaycal.DisplayCAL net.sourceforge.qtpfsgui.LuminanceHDR
markman8@pc-57:~> flatpak run
Qt: Session management error: Could not open network socket
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
markman8@pc-57:~> flatpak run -l
Device is not found…

markman8@pc-57:~> scanimage -L
device `epkowa:interpreter:002:005’ is a Epson Perfection 4490 flatbed scanner

Here it is Mica. When I run it through the cli it pops out the window but without any scanner in the list. Just Add which looks for scanners on the LAN.

Can you run flatpak override --filesystem=host

Then launch it from the CLI again?

error: Failed to create file “/var/lib/flatpak/overrides/”: Permission denied

Shall I sudo run it?


Done… same results. “Devise is not found…”

I’d open a bug on the flatpak’s github repo

1 Like