Error message when calling plugin with a fave filter selected

Hi, I am using G’mic with the latest version of Affinity Photo. If I exit the plugin with a filter in the Faves section selected I get the error message shown in G’mic 1.png when I try to use the plugin again. This doesn’t happen if I select the same filter from the main filter categories (see G’mic 2.png). The same thing happens whatever filter is selected in Faves. Any ideas please. Thanks

Remember to ping @PDN_GMIC.

1 Like

Looks like an issue specific to the 8bf plug-in interface (tested here with GIMP, and it seems to work).

It definitely looks like it’s to do with the 8bf plugin. Just tried the same workflow in Photoshop Elements with the same result.

This appears to be a bug in the filter parameter handling for the G’MIC-Qt UI.
It only occurs if the last filter was in the user’s favorites and G’MIC-Qt was started with the following arguments:

GmicQt::run(GmicQt::UserInterfaceMode::Full, GmicQt::lastAppliedFilterRunParameters(GmicQt::ReturnedRunParametersFlag::AfterFilterExecution), ...);

The GIMP plugin does not use that argument combination.

OK, I’ll forward the message to Sébastien then.
Not sure but he is probably in vacations right now.

@PDN_GMIC , Sébastien has apparently fixed the bug in ght G’MIC-Qt sources : Commits · c-koi/gmic-qt · GitHub (commits done on 2021/08/20).
I’ve released 2.9.8 just before the holidays, so I’ll probably won’t release a 2.9.9 version of G’MIC just for this change, but you may still want to try with the current dev version.

I can confirm that the bug has been fixed.
Released version of the 8bf filter with the updated build of G’MIC-Qt.

1 Like

Thanks for sorting this out. Regards, Geoff