Error opening Hugin


(David LaCivita) #1

Spring is here so I was out shooting and tried to make a panorama. I got my shots home and tried to start Hugin but I get the following error and then it crashes. I’m running Ubuntu 15.10 and just added the PPA and update to latest Hugin version.

I have no idea what any of this means.

ASSERT INFO:
/usr/include/wx-3.0/wx/object.h(160): assert “wxDynamicCast(ptr, T)” failed in wxCheckCast(): wxStaticCast() used incorrectly

BACKTRACE:
[1] GLPreviewFrame::SetGuiLevel(GuiLevel)
[2] MainFrame::SetGuiLevel(GuiLevel)
[3] MainFrame::MainFrame(wxWindow*, HuginBase::Panorama&)
[4] huginApp::OnInit()
[5] wxEntry(int&, wchar_t**)
[6] main
[7] __libc_start_main
[8] _start


(Pat David) #2

Did you follow this for installation?

http://wiki.panotools.org/Hugin_Compiling_Ubuntu#Shortcut

Stable

This will install the latest stable version of the tools:

sudo add-apt-repository ppa:hugin/hugin-builds
sudo apt-get update
sudo apt-get install hugin enblend panini

Unstable

sudo add-apt-repository ppa:hugin/hugin-builds
sudo add-apt-repository ppa:hugin/nightly
sudo apt-get update
sudo apt-get install hugin enblend panini

(Jonas Wagner) #3

Not much more than ‘I can’t turn something into something else’ really.
If I had to take a random guess it’s some sort of version mismatch.


(David LaCivita) #4

@patdavid I did not but will do so now. Thanks.


(David LaCivita) #5

Hmm…? I did add the stable ppa and I can install hugin and enblend but I get “Unable to locate package panini.”

UPDATE: I add the nightly ppa and it still can’t find panini.


(Pat David) #6

I wonder if @Morgan_Hardwood might have any insight?

I’ve got a 15.10 lying around. I’ll give it a try also a little later and see if I can replicate the problem.


(Pat David) #7

I just tried this on my Ubuntu Wily (15.10).

sudo add-apt-repository ppa:hugin/hugin-builds
sudo apt-get update
sudo apt-get install hugin enblend enfuse hugin-data

This seems to work ok.
I can launch Hugin (though there’s a ton of gtk-CRITICAL assertions on a widget size).

These are the packages installed (and suggested) from the above apt-get install.

The following extra packages will be installed:
  freeglut3 hugin-tools libimage-exiftool-perl libpano13-3 libpano13-bin
  libvigraimpex5v5 libwxbase3.0-0v5 libwxgtk3.0-0v5
Suggested packages:
  python-wxgtk3.0
The following NEW packages will be installed:
  enblend enfuse freeglut3 hugin hugin-data hugin-tools
  libimage-exiftool-perl libpano13-3 libpano13-bin libvigraimpex5v5
  libwxbase3.0-0v5 libwxgtk3.0-0v5

I see that the last build for panini was for Quantal:
https://launchpad.net/~hugin/+archive/ubuntu/hugin-builds

There are other builds you could possibly try, including nightlies and next builds.
https://launchpad.net/~hugin


(Morgan Hardwood) #8

I compile my own Hugin from mercurial. Don’t bother with Panini, it’s dead.


(David LaCivita) #9

Everything was installed and on the latest version except the python package. I keep getting the same error. I removed the ppa and used Synaptic to remove everything related to “hugin” and started fresh. I ran: [quote=“patdavid, post:7, topic:1009”]
sudo add-apt-repository ppa:hugin/hugin-builds
sudo apt-get update
sudo apt-get install hugin enblend enfuse hugin-data
[/quote]

I started hugin from the command line and got:

dave@dave-K55A:~$ hugin
01:31:31 PM: Debug: Failed to connect to session manager: SESSION_MANAGER environment variable not defined

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): GdkPixbuf-CRITICAL **: gdk_pixbuf_new: assertion ‘width > 0’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): GdkPixbuf-CRITICAL **: gdk_pixbuf_new: assertion ‘width > 0’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed

(hugin:8809): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion ‘height >= -1’ failed
/usr/share/hugin/data/plugins/shooting_pattern.py
CAT:initial distribution
NAM:6-1-1 Shooting Pattern
/usr/share/hugin/data/plugins/woa.py
CAT:Control Points
NAM:Warped Overlap Analysis
/usr/share/hugin/data/plugins/crop_cp.py
CAT:Control Points
NAM:Crop Control Points
/usr/share/hugin/data/plugins/top_five.py
CAT:Control Points
NAM:keep 5 CPs per image pair
/usr/include/wx-3.0/wx/object.h(160): assert “wxDynamicCast(ptr, T)” failed in wxCheckCast(): wxStaticCast() used incorrectly
Trace/breakpoint trap (core dumped)

I’m so confused… :anguished:


(Pat David) #10

This seems to indicate a problem with wxWidgets. Did you have something else using that? (the …/wx-3.0/ might be helpful?).


(Morgan Hardwood) #11

For what it’s worth, I’m using:
wxpython-2.8.12.1
wxwidgets 2.8.12.1 and 3.0.2.0


(David LaCivita) #12

I don’t know what wxWidgets is.


(Morgan Hardwood) #13

You don’t need to, just search your system for that package and see what version you have, and try upgrading or downgrading to my version.


(David LaCivita) #14

As best I can tell I’ve got the same versions as @Morgan_Hardwood but the normal package_name --version (or -version or -v) doesn’t work. I’ve added ppas and updates from all over the internet for wxwidgets and wxpython, specifically looking the correct versions. When I start from command line I still get the same errors.

And thanks for the help, if my questions lead you to believe I have no idea what I’m doing, you would be correct.


(Pat David) #15

Well, part of the problem is that you shouldn’t have to know all this just to be able to use Hugin. I’m sure it’s something silly that we’ll figure out sooner or later… :frowning:


(Mica) #16

I’ve moved this post to our shiney new category and removed the other post that just linked to this post.

I’m not sure if regular users can change categories, but if you want a change in the future, just ping me, I’ll take care of it.


(David LaCivita) #17

I finally figured this out and I feel not so smart. Some how I checked a box about fast preview screens… If I control-click when I open Hugin I have the option to fix the problem. At least now I can play along with everyone now!


(Mica) #18

Success!


(Pat David) #19

Oh man, this bugged me for a while also… Glad you got it sorted!


(Adm Odnar) #20

Me also! I had no idea that the Ctrl-click on start was even an option and had been very frustrated with trying ppa, re-install, and etc, but kept getting that same message.
THANK YOU!!