Error processing queue: "Invalid byte sequence in conversion input"



I’m macbook pro with El Capitán user. I put 20 photos in queue and clicked “Start processing”, to the output directory marked “Save do folder”. Rawtherapee return that message: Invalid sequence in conversion input. Camera: Nikon d800, raw and jpg files.


(Morgan Hardwood) #2
Tell us more. Try more.
Does it always happen? Did saving any of the images work?
What were the image filenames?
Upload the contents of the “batch” folder which is found in the “config” folder
Try processing this raw


Hi Morgan,
Thanks for answer. 1. I’ll keep trying with other files. 2. This has happened tree times with the same files. 3. So, I am following your suggestions. I’m new to it in Mac; it usually works in Windows 10 version. I return my results.


Hi Gustavo,

I think I was facing the same problem. Was your path names contain some multi-byte characters? If so, here’s my workaround to this problem.

In a terminal, go to /Applications/, edit the shell script called “rawtherapee”, insert the following line before “exec … rawtherapee-bin”.

export LANG=`defaults read -g AppleLocale`.UTF-8

It is working for me. Hope this helps you too.



Hi tokiwai

Thank You! It did work!


Enviado do Outlook Mobile

(Morgan Hardwood) #6

Anything we can do upstream to fix it for everyone? Please be clear, I don’t have access to and can’t test on and don’t speak Mac.


I hope the change, or any other fix for this problem is included in future releases for OSX.

As the version of the shell script “rawtherapee” I see seems to be OSX specific, I think it is not hard to checkin my change to the repository. But unfortunately, I’m new to RT world and completely ignorant about who is doing what. I think just sending a message to one of the maintainer for OSX will do, but who is he/she?


(Morgan Hardwood) #8

With your help it could be.

There are three of us here in Discuss, they’re @heckflosse, @jdc and myself. None of us have OS X, but with help from user’s I’ve been trying to fix things related to OS X, so I want to add this change too.

The file in question is this one:

diff --git a/tools/osx/ b/tools/osx/
index 5f1911e..98747c7 100644
--- a/tools/osx/
+++ b/tools/osx/
@@ -28,4 +28,5 @@ case $1 in -psn_*) shift;; esac
 ln -sf "${app}" /tmp
+export LANG=`defaults read -g AppleLocale`.UTF-8
 exec "${cwd}"/rawtherapee-bin "$@"

Is this change safe for OS X 10.11, 10.10 and 10.9?


Hi Morgan,

Thanks for the explanation and your work for OSX. I realized I have already strayed into the right place. :cat2:

  1. After some more reserch, I found my original change does not work in some cases. Could you please change the fix to inserting the following two lines?

    AppleLocale=`defaults read -g AppleLocale`
    export LANG=${AppleLocale%@*}.UTF-8

  2. I run this on OSX 10.11, and it should on 10.9 and 10.10 either.

(Daniela A) #10

Hi everyone!
I am from Uruguay, therefore I speak spanish.

I need help with saving photo in MAC OS Sierra- last update for mac. I use an Imac, as my sole computer.
I am very but very new to RT, in fact I tend to use Lightroom, but I found this programm very exiting , it has lots of
sliders and much more control than LR.
But when I tried to save my raw image in JPEG, I got the same message of "Invalide byte sequence…"
How do I fix this? Pls take into acc. that I am old, and not a programmer at all.
Thanks a lot for any help!
Best wishes

(Mica) #11

Hi @Daniela, can you please post the full error message? Do you have any accented or special characters in your user name.on your computer?

(Morgan Hardwood) #12

@mmmtok @partha @Daniela could you confirm that the fix from comment Error processing queue: "Invalid byte sequence in conversion input" works for you and that we should add it?


I don’t get the error mentioned above. Of course, I am still doing this from the command line and have not built the App yet.


Hi Morgan,

I confirmed on macOS Sierra with recent RT/ports that I still need the change in the comment.
I think it is better to commit, though I’m not sure it solves Daniela’s problem.

(Morgan Hardwood) #15

What is macOS Sierra? Please provide the version number everyone can understand, not a version name.

(Flössie) #16


(Daniela A) #17

Mac os Sierra 10.12.1 (16B2555)
I am sorry, I don’t really understand the topic that you mentioned in brackets…
The error comes whenever I am going to export a photo. I tried it several times, with different photographs.
I want to choose a special folder, in my documents, and it seems that it will export, but it doesn’t.
@paperdigits Paperdigits, what do you mean by “accented or… in my user name on my computer”? Where should I look at that.
I know that perhaps, beign an ignorant of programming and any programming language, will make things more complicated, but the worst part is being a spanish speaker…
I am doing my best to try to understand you all.
I am going to reedit another photograph and will copy /Past the full error, plus processing I do Ok?
Thank you so, so much for trying to help me. I love open source ideas, yet, and as I told you it’s not easy when you come from the paper, pen, and abacus era :slight_smile:
best wishes to all of you,


(Morgan Hardwood) #18

@Daniela the error might be coming from special characters in the photo’s filename, the folders in the source or output path, or metadata in the raw file. Please try these things in this order:

  1. Upload the raw file using and paste the full path (source and destination) here.
  2. Find RawTherapee’s executable_loader file (maybe @mmmtok can tell you where it is, I don’t have OS X) and above the “exec” line add these:
AppleLocale=`defaults read -g AppleLocale`
export LANG=${AppleLocale%@*}.UTF-8

See if RT still crashes after this change.
3. Eliminate all special characters from the crashing image (remove them from the filename, folders and from metadata if any) and try again.

RT crashes when trying to open processing queue


Here is how to do for Morgan’s #2. I assume RawTherapee is installed under “Applications” folder.

  1. Open “Applications” folder with Finder.
  2. Find “”
  3. Ctrl + click “”
  4. Select “show package content” (The string varies by language settings. There should be one meaning this.)
  5. You’ll see “Contents” folder
  6. Go into “Contents” and find “MacOS”
  7. Find “rawtherapee” in “MacOS” folder.
  8. Ctrl + click “rawtherapee” (NOT “rawtherapee-bin”)
  9. Select “open with this application”->“other” (The strings vary by language settings)
  10. A dialog opens.
  11. Select “” and push “Open”
  12. A TextEdit window opens.
  13. You’ll find “exec …” at the last line
  14. Paste two lines just above “exec …”
  15. Save the file
  16. Done.

@Daniela @Gustavo If you would like to test, here is a new build with the above mentioned Error processing queue: "Invalid byte sequence in conversion input" language locale fix in the executable loader.