Error reading cr2 raw files in version 2.4

I used to be able to read .cr2 canon raw camera files directly on Natron 2.3.15. (How to set the options for decoding a raw camera file when creating a node with python?)

I tried to do that in release 2.4 and I get the following error:

Screenshot from 2021-10-20 10-08-51

Windows/Linux/macOS? Have you tried the latest RC? If Linux did you use the official release (downloaded from GitHub)?

Using Linux. Downloaded file from

Aparently the OpenImageIO version is not compiled with libraw.

@rodlie same missing library on the 2.4.1 RC snapshot. It won’t find the decoder (OpenImageIO ?)

You are correct, the Linux builds don’t have libraw support since 2.4. We will fix this before release of 2.4.1.


Thank you for reporting, I’ll fix it:

For more visibility and tracking, please file the bug report on github next time (I created one for this issue, see below). This helps a lot. For example, we can track back from the Natron change log to the issue numbers, the corresponding fixes, and the discussion.