Error trying to build in Kubuntu 20.04 (SOLVED)

Hi.
I can compile Darktable from master without problems in Kubuntu 18.04. But I have problems in Kubuntu 20.04. Here error messages and more information about my system:

$ ./build.sh --prefix /home/yafu/.darktable_master --buildtype RELEASE
Darktable build script

Building directory: /media/Disk1/@@Darktable_Git/darktable/build
Installation prefix: /home/yafu/.darktable_master
Build type: RELEASE
Build generator: Unix Makefiles
Build tasks: 8

CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/home/yafu/.local/share/cmake-3.15
CMake Error: Error executing cmake::LoadCache(). Aborting.

===================

====
$ cmake -DCMAKE_INSTALL_PREFIX=/home/yafu/.darktable_master/ -DCMAKE_C_COMPILER=gcc-7 -DCMAKE_CXX_COMPILER=g+±7 -DCMAKE_BUILD_TYPE=Release …
bash: /home/yafu/.local/bin/cmake: /usr/bin/python: bad interpreter: No such file or directory

===================

====
whereis cmake
cmake: /usr/bin/cmake /usr/lib/x86_64-linux-gnu/cmake /usr/lib/cmake /usr/share/cmake /home/nulluser/.local/bin/cmake /usr/share/man/man1/cmake.1.gz

===================

====
$ sudo dpkg -l | grep -i cmake
ii cmake 3.15.4-1ubuntu3 amd64 cross-platform, open-source make system
ii cmake-curses-gui 3.15.4-1ubuntu3 amd64 curses based user interface for CMake (ccmake)
ii cmake-data 3.15.4-1ubuntu3 all CMake data files (modules, templates and documentation)
ii cmake-mio 3.15.5-1 amd64 cmake 3.15.5 from sources

==================
EDIT (SOLVED):
I just realized that there is a residual cmake locally installed in “/home/yafu/.local/bin/cmake”, probably manually installed long ago (system updated from an 18.04 installation). I have deleted it and now I can compile.

Do you have cmake and Phyton installed on your system?

Yes, they are installed:

https://pastebin.com/VcxgCFhA

Edit:
I just realized that there is a residual cmake locally installed in “/home/yafu/.local/bin/cmake”, probably manually installed long ago (system updated from an 18.04 installation). I have deleted it and now I can compile.

1 Like