Error while opening FITS file

Hello, today I decided to try to process one of JWST’s latest images and run in a problem that I wasn’t able to open FITS file that I downloaded. Link to the file - https://drive.google.com/file/d/13KhxxjWmStMrbJMryz5Ed9Oc2EADel7-/view?usp=sharing
Is there a way to fix this?

Hello, the file is too big, can you tell us what the error is instead?

1 Like

This is the only thing about error in the console: Opening jw02731-o001_t017_nircam_clear-f335m_i2d.fits failed.

I am having the same issue.

The console says:

18:02:59: Welcome to siril v1.0.3
18:02:59: Supported file types: BMP images, PIC images (IRIS), PGM and PPM binary images, RAW images, FITS-CFA images, Films, SER sequences, TIFF images, JPG images, PNG images, HEIF images.
18:02:59: Loading init file: ‘/Users/MYHOME/Library/Application Support/siril/siril.config’
18:02:59: Parallel processing enabled: Using 10 logical processors.
18:03:00: Setting CWD (Current Working Directory) to ‘/Users/MYPATH/MAST_2022-07-17T1710/JWST/jw02731-o001_t017_nircam_clear-f335m’
18:03:00: Searching scripts in: “/Applications/SiriL.app/Contents/MacOS/…/Resources/share/siril/scripts”…
18:03:00: Loading script: Mono_Preprocessing
18:03:00: Loading script: OSC_Extract_Ha
18:03:00: Loading script: OSC_Extract_HaOIII
18:03:00: Loading script: OSC_Preprocessing
18:03:00: Loading script: OSC_Preprocessing_WithDrizzle
18:03:00: Loading registration method: One Star Registration (deep-sky)
18:03:00: Loading registration method: Two or Three Stars Registration (deep-sky)
18:03:00: Loading registration method: Global Star Alignment (deep-sky)
18:03:00: Loading registration method: Image Pattern Alignment (planetary - full disk)
18:03:00: Loading registration method: Enhanced Correlation Coefficient (planetary - surfaces)
18:03:00: Loading registration method: Comet/Asteroid Registration
18:03:00: Default FITS extension is set to .fit
18:03:11: Setting CWD (Current Working Directory) to ‘/Users/MYPATH/MAST_2022-07-17T1710/JWST/jw02731-o001_t017_nircam_clear-f335m’
18:03:11: Opening /Users/MYPATH/MAST_2022-07-17T1710/JWST/jw02731-o001_t017_nircam_clear-f335m/jw02731-o001_t017_nircam_clear-f335m_i2d.fits failed.

I was able to open the same FITS file in ASTAP. The file was downloaded from: STScI | Mikulski Archive for Space Telescopes (MAST) Portal
Proposal 2731,

The file contains several images that have different dimensions. Because most algorithms in siril rely on all images of a sequence having the same dimensions, we only open FITS cubes that have images of identical dimensions. Maybe we’ll fix that in the future, but it’s not easy.

A workaround would be to split the file into several FITS files, or use another tool to display the images, for example ds9 which is made for science use.

2 Likes

I’m having the same problem right now with the JWST photos. Thanks for the help.

I’m getting the same error

Interesting: four new users. Welcome @VoidStorm @khurrum @Pabmarex @alexandreff.

1 Like

In fact the file contains a main image and several other calibration and scientific data, I found a workaround to access the main image: configure the file extension in siril to be the same as the image, or rename the image to have the same extension as siril’s. Default is .fit, changing it to .fits (in preferences or with command setext fits) will open the FITS cube in a way that allows a part of it to be accessed.

2 Likes

Changing the preference worked. Now to figure out a process flow for false colorizing the filtered JWST images that are becoming available. Would this be a good tutorial topic? I found an article that might be of use for SIRIL users that covers monochrome colorizations, Siril.org RGB composition, written by Vincent Hourdin (what a surprise). Thanks for the help I was reviewing this while trying to download the new images, hoping to try my hand with Siril.

Would this be a good project to develop a script that standardizes the first cut at the various wavelength images?

Hello and welcome!
The RGB composition tutorial is a bit outdated with the arrival of the PixelMath tool, and in the development version there is also a new rgbcomp command that will help this. The current tool is stlll around and only available in the GUI, so no script will be possible.

That being said, the stable version of siril has problems with that kind of files. If you just want to use the first image of each file, it should be fine, but accessing the others is failing. I think in 1.0.4 I will only allow the first image to be opened as a simple FITS image, and in the development version provide access to all images.

Good luck :slight_smile:

Thank for the info in this topic. I am new to SiriL. I have been looking at the various apps and workflows for use with the JWST datasets. I am just trying to understand what different apps are capable in analyzing and post processing data from JWST. This has helped me continue to learn what SiriL can do with the data.