Error while rendering: Rendering Failed / return code is 0


First of all thank you for the hard work put into Natron :wink:

I am using Natron 2.4.3 on Windows in a render farm setup and I tried launching a render with a write node (checked read back file) that points to nothing (the file sequence does not exist).


I got the following error log while trying to render Write2:

Restoring the image cache...

Loading plugin cache...

Info: script not loaded (this is not an error)

Loading PyPlugs...
Loading project: P:/test_pipe/shots/s03/p060/layout_main/publish/v000/ntp/project.ntp
Error while rendering: Rendering Failed

(process:7944): GLib-GIO-WARNING **: 14:17:28.960: Unexpectedly, UWP app `Microsoft.MSPaint_6.2203.1037.0_x64__8wekyb3d8bbwe' (AUMId `Microsoft.MSPaint_8wekyb3d8bbwe!Microsoft.MSPaint') supports 17 extensions but has no verbs
Write2 ==> Rendering started
Persistent message: Could not open "P:/test_pipe/shots/s03/p060/layout_main/publish/v000/exr/render/Write1/test_pipe_s03_p060_layout_main_publish_v000_render_Write1.0001.exr" (No such file or directory)
Write2 ==> Rendering finished

Natron reports correctly that the files are missing but the return code is still 0, leaving the task in success state and not error.

Is it a wanted behavior or this needs to be fixed? As an artist I want to be warned with an error if a read node doesn’t find a file.



Return codes from Natron is not usable, they will not return what actually happened. I consider it a bug, but it’s implemented like this (still not good). It’s also not a trivial fix (at least that was my conclusion a couple of years ago).

1 Like

All right thanks @rodlie.

Should we open an issue on GitHub to track this? It’s not urgent right now I have a workaround…

Sure, if it’s not there already (don’t remember).

I can take a look at this issue again, but it will probably have to wait until next month.

Thanks I’ll do it (I found nothing about return codes already) :wink: