Error while using Gmic for Krita

I am trying to apply some filters from Gmic, but I get error like these. These errors mostly occur on color filters. Most other filters work fine. Any suggestions for solving this?
I have working network and when I try to acces given url on browser, I can access the files just fine.

I am using Gmic that comes with Krita. Is there an additional step to install/use Gmic?
I am on Windows 10. I am using Krita 4.3. I even tried it with Krita 4.4 alpha, but still got error. Honestly, This error has always been there for me since I started using Krita few years ago. I always thought maybe these filter are discontinued or something.
But I saw people using them on youtube tutorials, and I couldn’t access it. :frowning:
Is it something to do with my hardware? I have very old laptop. 4 gb RAM and nvidia geforce 820m 2gb.

I posted this on Krita forums and was directed here.

@Anurag_E Welcome to the forum!

Try installing a newer version of the plugin and then update your filters with the update button at the bottom left. It can be found here:

Thanks for replying.
How do I manually update gmic? I have downloaded the zip but don’t know what to do with the files.
And I have already updated the filters many times. I can update filters easily. But the errors are still there. On Krita forums, I was told it may be firewall issue. I added Krita and gmic to allowed programs. Still it didn’t help.

For now, the only solution seems to manually download all .cimgz and .gmic files and put it in gmic folder. The filters are working that way.

@Anurag_E I would install G’MIC CLI, and add it to the environment path. I was able to update Krita by using gmic up command on command prompt. That’s what I’m using for now.

I am not well versed with CLI but I will look into it. Thanks.

I am not using Krita, still the path for those files can be found under “$_path_rc”. Hence use gmic with a bright image in Krita, go to >Various>Custom Code [Global] and type in the window there “text $_path_rc”, without ". Hopefully the path on your system will be printed into the image!

As I see it, the OP has Krita with a year old G’mic 2.7.1 installed. It must have connected to the internet sometime in the past, the screenshot shows 522 filters.
…but not connecting now. The usual question what changed in that timespan. Windows updates, AV changes, perhaps some filtering by the ISP, who knows.

It is very easy to add G’mic to Krita, even for me a Gimp user. Get the zip, unpack it somewhere, find it in Krita preferences, add the path. This G’mic 2.9.1 Krita 4.3 .0 which updates here in a Win10 VM to 544 filters. If OP has problems with a G’mic internet connection a new install might be a backward step. Not a disaster if the previous G’mic is in a different folder.

The bundled data is described in Gmic menu: About > Download External Data 70 something MB Worth a try.

Yeah, manually placing those files in gmic directory works!

Installing to Krita is very simple. Extract archive to your preferred location and then specify it in Krita. The reason you have to upgrade the plugin version is that older versions are restricted from updating newer filters and newer filter changes because of compatibility issues. E.g. since most of mine experience rapid development, one would have to almost always upgrade to the latest plugin in order to use them.

1 Like

Thanks, will try this!