Exclusion blend mode not working

I’ve made an image in GIMP and Inkscape that I’m bringing into Natron to animate a bit. In GIMP and Inkscape I added a layer filled with red (#FF0000) and set the blend mode to Exclusion.

This is the original image:

This is it after the red layer set with blend mode set to Exclusion is added:

When I bring the original into Natron and try blending it with red using a merge node set to Exclusion the output looks like this.

As you can see it isn’t right! I’ve tried other layer blend modes in Natron and none of them replicate what GIMP/Inkscape produces. I’ve tried the same blend modes in Krita as well and Natron is the only one with this output. Anything I can do to correct it?

Exclusion works for me, what are the settings for the merge node? a screenshot of the project (or even better the project files) would help.

William Young on Facebook suggested that the colorspace settings in the Read node might be the problem and I think he’s right. I am reading a .psd file generated by GIMP. Imagemagick tells me that its colorspace is sRGB, and so in the Read node I set the Output Colorspace to sRGB.

The image now looks closer to the original but it’s still washed out. I’ve been working on the image since yesterday so it now looks a bit different.

Here’s the project files.

project_files.zip (4.2 MB)


I spoke with Troy outside of the forums and, although I’m still not 100% on the maths behind it, it boils down to colorspaces on the Read node and on the Write node.

I set the File and Output colorspace on Read node to Linear and in the Write node also set it to Linear.