Export with upscaling turned on - sometimes it fails

Can someone help in my understanding . Why does export fail when the Upscaling is turned on in the export module for some photos, while it is fine with other pics?. If need be, I can attach the raw files of each case

Please share an example with the sidecar to see if others experience the same problem. Also, indicate the version, where it came from and your configuration. BTW, fixed the category for you.

Sure, Here are two examples. The first one is a ‘play raw’ download, taken on Fuji Film, .RAF extension as per the image information. It is taken from the forum post Color Calibration Problem, the second one is taken on Panasonic LX3,. .RW2 extension with my camera

For the .RAF file, the export command goes thru when the ’ allow upscaling’ is set to ‘no’. I always export to ‘file on disk’

Both pictures are processed with DT 4.7 + 1229. The problem happens with the .RAF file when the ‘allow upscaling - set to ‘yes’’ in the export module

DSCF2616.RAF.xmp (14.2 KB)
DSCF2616.RAF (48.2 MB)

P1010868 .RW2.xmp (13.1 KB)
P1010868 .RW2 (11.1 MB)

These files are licensed Creative Commons, By-Attribution, Share-Alike.

Can you start darktable -d common and post the output? When you say fails, it means what? dt crashes? black image?

Response is “could not export to file…”, it creates a 0 byte file. However, when I toggle it to ‘allow upscaling’ to no, the file is exported correctly.

I am running darktable in windows environment, so the command simply starts dt normally

On Windows the log is output to a file, please check the FAQ and the manual for its location.

Here is the log file. My current DT version is 4.7-1233, and the image in question is DSCF2616.RAF

darktable-log.txt (1.4 MB)

BTW, if this is of any help. For external pictures, like the ones from camera raw, I drag and drop the image to an assigned folder in the lighttable view, rather than ‘copy and import’

I’ll have to update and retry but on 4.7 + 1061 it doesn’t seem to happen for me…I tried several combinations of settings and sizes and all exported…

Edit…I just built 4.7 +1237 and running on Win11… no issues to export that raf file… I tried again changing to give several combinations of size and ratio with yes for upscale and both yes and no for HQR. Still no issue for me…Does this image consistently fail to export for you??


I think it see an issue in the ROI IN for the demosaic (699.1454 seconds). I think the best course of action is:

  1. delete your current log file so we have a clean one.
  2. do the darktable -d common -d pipe with only exporting that single image with upscale to yes (to focus only on this)
  3. start an Issue in GitHub and attach the new log there.

Can you confirm that you are not using the GPU? It looks like it was disabled. Maybe attach also the output from darktbale-cltest too.

This problem is appearing only when I am ‘drag and drop’ a play raw file that i downloaded to some other directory, then copied to the file to the directory where I keep all the ‘play raw’ files. I then open DT and drag and drop onto the lighttable view and start the processing. The other photo that I had attached, the .LX3 file I brought it to DT using the ‘copy and import’ command.

I will try doing it thru the ‘copy to library’ command to see if anything different happens.

When I delete the log file, start DT and give the export command, the only entry is a single line ‘Empty JPEG image (DNL not supported)’

This BTW is a recent problem, didn’t face it ’ say 2 weeks back. Don’t remember the 4.7 version

g-man, are the commands you are suggesting are for the linux version? I am running windows-11, on a laptop

Todd Prior - the failure is consistent, and for every file that I drag and drop into lighttable view. No problem when I copy&import the LX3 files from the SD card

It would be best to use -d pipe -d imageio as that reports best for exporting.

Also the log indicates you are appending a style, would you share that?

I see I never do that. I just assumed to correctly manage the database you need to use import…Maybe that is why I don’t see it??

The problem remains even after I used the import command to add a picture. Have opened a bug report on GitHub. At present, I will export without the scaling option yes for the offending photos :unamused:

It is a pastel style, affecting color zones, color balance RGB and local contrast modules