Exported file looks different from darktable view

First time using darktable (version 4.2.0, Windows 11). From what I’ve seen, my exports look overexposed compared to the view I have when editing the photos in darkroom (example photo below). They seem to look more like the previews in lightroom. I’m not sure what I might be doing wrong, but how can I get my exports to look like the photos in darkroom (I would prefer to be able to keep the edits / have the export look like the view in darkroom). Thanks!

What is your output color set to (the module on the top right of your image)?

What is your display profile set to?

My output profile is “sRGB (web-safe)”. Display profile appears to be “system display profile”

I see that changing the display profile to sRGB matches the darkroom view with the exported output. Is there anyway to have the export use the system display profile as opposed to sRGB? I don’t see “system display profile” as an option for output color profile.

Do you have a wide gamut display? Is your display calibrated (to around 120cdm)?

Is the program you are using on the right side, color managed?

Basic displays are usually not too far from sRGB. This means that if a non-colour-managed software, e.g. Windows Photo Viewer, displays a standard sRGB image, it will look reasonable on the display.

If you have a display profile, but it’s wrong, and you tell darktable to use it, you will produce a bad edit. That, when exported and displayed in the non-managed viewer, will look bad.

If you tell darktable to use sRGB as the display profile, you will see the image pretty much like in the non-managed viewer.

You could try the following:

  • save any image (e.g., a JPG) from your web browser that looks good;
  • import it in darktable;
  • if it looks good, your display profile is OK, and we’ll have to look elsewhere;
  • if it looks bad, then your display profile (which tells darktable how to ‘format’ the image to look best on your display) is wrong, and you should get a good profile.